Front blowers for heat not working

Tiny
MARK IACOPELLI
  • MEMBER
  • 2007 CHEVROLET UPLANDER
  • 160,000 MILES
My front blowers for the cabin don’t work. I was told by a more mechanically inclined friend that it’s probably the blower motor of resistor. I replaced the blower motor but didn’t work. Occasionally if I hit a bump just right the blowers kick on. The rear cabin blowers work fine. Could it still be the resistor? When they do kick on they seem to change speeds fine.
Do you
have the same problem?
Yes
No
Sunday, October 27th, 2019 AT 11:13 AM

3 Replies

Tiny
KEN L
  • ADMIN
Hello,

You replaced the blower motor correct? It sounds like it is going bad. To be sure lets use this guide to see if it is getting power/ground:

https://www.2carpros.com/articles/how-to-use-a-test-light-circuit-tester

This blower wiring will show you how the system works. There is a blower relay that needs to be checked as well.

https://www.2carpros.com/articles/how-to-check-an-electrical-relay-and-wiring-control-circuit

Here is the location below. Check out the diagrams (below). Please let us know what you find. We are interested to see what it is.
Was this
answer
helpful?
Yes
No
+1
Monday, October 28th, 2019 AT 6:05 PM
Tiny
MARK IACOPELLI
  • MEMBER
Yes, I replaced the blower motor thinking that was the problem. In hindsight I this it was fine. I will go through the steps you suggested an see what I find and let you know. Winter is coming and I am not prepared.
Was this
answer
helpful?
Yes
No
Tuesday, October 29th, 2019 AT 10:07 AM
Tiny
KEN L
  • ADMIN
Yep, check for the relay failure first. Let me know.
Was this
answer
helpful?
Yes
No
Tuesday, October 29th, 2019 AT 10:51 AM

Please login or register to post a reply.

Sponsored links