1994 Thunderbird Has Me Puzzled!

Tiny
94T-BIRDGUY
  • 1994 FORD THUNDERBIRD

1994 thunderbird, 3.8, auto,..NOT SC...ok-

just swapped tranny...completed this and car started and ran great for two weeks...alternator stopped charging so i just swapped that out...now immediately I hopped in to start her up to make sure this BRAND NEW not Rebuilt Alt. was charging and that was that and.........turned key, very quick like split second churn by the starter and then ALL of the car lost its power from the battery...no lights no nothing, car is completely dead...now, i checked all fuses and relays- OK- while i was standing there PUZZLED with the doors open, all of a sudden the Interior lights kicked on???? Now can you say HAUNTED? just kidding...so I happily climbed in and turned the key again...SAME RESULT...starter cranked for a split second and car lost ALL ELECTRICAL FLOW THROUGHOUT...any suggestions>?


http://www.2carpros.com/forum/automotive_pictures/104074_7ef1c6c91ec7dd47b0ae045ea02cf150_1.jpg

Do you
have the same problem?
Yes
No
Tuesday, October 2nd, 2007 AT 12:41 PM

1 Reply

Tiny
POET042005
  • MEMBER

CHeck the connections on the side of the fuse box under the hood. Wiggle the wiring as you go to check for shorts. Next (if you have not already checked the battery connections do so 4 corrosion and tightness) CHeck 4 loose or corroded grounds.

Sounds like you have a bad connection.

______________________
I try to answer questions as though it were my car, like I m standing in your shoes looking to diagnose the problem.

Was this
answer
helpful?
Yes
No
Monday, October 8th, 2007 AT 3:36 PM

Please login or register to post a reply.

Other Transmission Replace/Remove Questions