1999 Ford Taurus Speedometer will not function, shifts are

Tiny
ICARUS02
  • 1999 FORD TAURUS

Transmission problem
1999 Ford Taurus 6 cyl Front Wheel Drive Automatic 94500 miles

I bought my 99 taurus about 2 years ago with 82k miles. About a year ago, I noticed that the speedometer would go crazy at times, but it didn't bother me very much because it would always work afterwards. Recently (a few days ago) my speedometer stopped working all together. In addition to this, the shifting has become terrible. The RPMs will rev to about 4-5k and hold for a while before shifting. Looking on some forums, they said this could be symptoms of a faulty ABS unit so I disconnected the unit, but no such luck. I am not sure what the problem could be. Thanks in advance!

Do you
have the same problem?
Yes
No
Monday, March 30th, 2009 AT 1:40 PM

3 Replies

Tiny
ZACKMAN
  • MEMBER

Try checking your VSS Vehicle Speed Sensor. It is responsible for speedo and transmission shifting operations. Located at rear center of engine compartment, mounted on the transaxle.


http://www.2carpros.com/forum/automotive_pictures/55316_99taurusengine1_1.jpg



http://www.2carpros.com/forum/automotive_pictures/55316_99taurusengine2_1.jpg

Was this
answer
helpful?
Yes
No
+1
Tuesday, March 31st, 2009 AT 12:41 AM
Tiny
ICARUS02
  • MEMBER

Just to update -- It was in fact the VSS that was causing my problems. It was a very quick and easy replacement (once the part was located). The car is moving much better now with all problems functioning the way they should. Thanks for the help!

Was this
answer
helpful?
Yes
No
+1
Friday, April 3rd, 2009 AT 5:10 PM
Tiny
ZACKMAN
  • MEMBER

Glad I can help.

Was this
answer
helpful?
Yes
No
Friday, April 3rd, 2009 AT 9:26 PM

Please login or register to post a reply.

Other Instrument Cluster Gauge Speedometer Not Working Questions