1997 Ford Ranger interior lighting

Tiny
GUITAR42
  • MEMBER
  • 1997 FORD RANGER
  • 6 CYL
  • 4WD
  • MANUAL
  • 85,607 MILES
The dome/glove box light and windshield wipers won't work(or do intermittently) and the problem happens only when it is raining. The "bright" engineers at Ford put the 4WD circuit on the same circuit as the dome/glove box circuit so they also won't work. I think the wipers are on a different circuit so this really adds to my frustration. I have changed/swapped out the fuses
in the cab and engine compartments and even the wiper, wiper hi-lo relays in the engine compartment. I also changed the wiper motor. All to no avail. I suspect possibly an ignition switch problem or an in-dash relay problem because when the dome light and wipers finally kick in, I here an in-dash relay "click"
Please help.I am completely baffled by this problem
as the problem happens only when it is raining outside!
Do you
have the same problem?
Yes
No
Sunday, March 9th, 2008 AT 6:56 PM

15 Replies

Tiny
SERVICE WRITER
  • EXPERT
Just gonna throw my 2 cents in.

I have seen intermittant problem with the dome light from a sticky switch in the latch assy. Plenty of thin viscosity fluid such as WD-40 will free them. Soaking them and open and shutting the door usually solve the dome light issue. But. It is typically not turning off.
Was this
answer
helpful?
Yes
No
Sunday, March 9th, 2008 AT 7:01 PM
Tiny
GUITAR42
  • MEMBER
Yes, but the wipers won't work at the same time when its raining or the wipers and dome will work intermitently. When the weather is fine, no problems. Dome/glove box light are turned on by switch in the door mechanism itself when the door is opened. Could something in the door which controls the dome/glovebox lights also affect the wipers? I don't see how.
Was this
answer
helpful?
Yes
No
+1
Sunday, March 9th, 2008 AT 7:23 PM
Tiny
SERVICE WRITER
  • EXPERT
I didn't look at the wiring diagram. But I am inclined to think not.I knew my thought was a little wild.
Have you looked at the diagrams? And look for any common connections? Maybe a poor gound issue?
Was this
answer
helpful?
Yes
No
Sunday, March 9th, 2008 AT 7:59 PM
Tiny
GUITAR42
  • MEMBER
Hey Paul,
yes but I only have a partial "Mitchell" power distribution circuit diagram. It shows a 20A "parking
lamp" circuit which feeds the dome/glove box lights.
Something about a "generic electronic module" and a
"battery saver relay". Both in the circuit. No mention
of wipers anywhere. To add to the mystery, I'll pull over when the problem occurs and turn the parking lamps on and they work! Fleet mech. Where I work said he saw where 4WD circuit is tied in on his computer but due to proprietary issues, he couldn't give me rest of schematic. He also said it could be my ignition switch. Something in the ignition switch just controlling the wipers and dome/glovebox which kind of makes sense. Do you know where I could get a really good schematic for this truck and what do you think? Beginning to believe this one's for the ages.
Ross :)
p.S. Before I bring it in(and I know THAT will be futile), I'd be willing and promise to send someone some $ if they can pin-point the prob once I fix it. THAT's a promise :)
Was this
answer
helpful?
Yes
No
-1
Sunday, March 9th, 2008 AT 8:17 PM
Tiny
GUITAR42
  • MEMBER
. Forgot to say. Yes, it could be a poor grounding issue but I have no idea where any of this is grounded. Dont see ground symbol anywhere in schematic.
Was this
answer
helpful?
Yes
No
Sunday, March 9th, 2008 AT 8:20 PM
Tiny
SERVICE WRITER
  • EXPERT
"pin-point the problem once I fix it?" LOL...


http://www.2carpros.com/forum/automotive_pictures/30961_cystal_ball_9.jpg



Anyways...I looked at the diagrams and looked at the grounding. Different grounds.

I would look at splice 221, as you can see they are all tieing into this except the wipers. Therefore I would first pull the connector at the GEM and inspect it for corrosion os such and be keep an eye for potential wetness. If the connector looks good I would pull aprt the splice and get a good look at it.


http://www.2carpros.com/forum/automotive_pictures/30961_ranger_1.jpg



I won't hold you to a donation, but I will continue to donate my time to you.
Was this
answer
helpful?
Yes
No
Sunday, March 9th, 2008 AT 8:51 PM
Tiny
GUITAR42
  • MEMBER
LOL. Yeah, that sounded dumb.I really didnt word that right. From where you are, this must be like trying to change a plug on a mars rover. Anyway, I was able to spend some time on this yesterday. Your heading in right direction. I found out dont think rain has anything to do with this when I started to reason this out. Prob. Presents itself when wipers are on when its raining, otherwise I wouldnt see the
prob.(No need to turn inside lights on during day and no rain). So, I said to myself, "Self, lets just sit here in drivers seat of this thing with dome light and wipers on and see whats up.(Ignition in "off" pos.)" Lo and behold, about 5 min. Into my experiment, dome light turned off, wipers stopped, then started, then hesitated, then dome light turned back on again. (Kept hearing relay in dash clicking). Waited a while(still with ig. In off position) and when it happened again, I turned truck on(ignition "run" and the prob. Persisted for about 5 seconds then lights stayed on and wipers worked normally. I looked in manual about "battery saver" and it said the battery saver should shut interior lights
off after about 40 min. Guess what I'm trying to say is, would you think it could have something to do with the "Generic electronic module"(I think thats what controls the battery saver relay or a relay perhaps? Will do as you suggested, but what think?
P.S. In my schematic, I saw where exterior lights are connected to this circuit and when prob. Was going on, checked parking lights etc; and they were fine.
Was this
answer
helpful?
Yes
No
Tuesday, March 11th, 2008 AT 5:36 AM
Tiny
SERVICE WRITER
  • EXPERT
Good logic-ing. Funny how you can associate clues incorrectly and try to make them fit into a scenario.

IF you look on the bottom of your post, you'll find a link to a repair manual that gives the testing for the GEM I believe. When I get time I'll see if I can find anything more helpful from that manual tonite.
Was this
answer
helpful?
Yes
No
+1
Tuesday, March 11th, 2008 AT 8:00 AM
Tiny
GUITAR42
  • MEMBER
O.K, Thank You for your help.I'd like to make a donation to you but am not sure I want to go the
"make a donation" route. I've always believed in compensatiing the person directly responsible(tip left on table so to speak.) If you want to provide an address that would be fine, otherwise I'll go through the tab. Again, Paul, Thank You.
Ross. :)
Was this
answer
helpful?
Yes
No
Wednesday, March 12th, 2008 AT 7:35 AM
Tiny
SERVICE WRITER
  • EXPERT
I appreciate it Ross, but it wouldn't be fair to the other guys that work equally as hard. They are going to be changing the format, but not sure when.

Regardless a donation throught the normal channel would be very much appreciated!
Was this
answer
helpful?
Yes
No
Wednesday, March 12th, 2008 AT 10:05 AM
Tiny
GUITAR42
  • MEMBER
Hey Paul,
o.K, but I tried to send through pay-pay which Ive
used before and it wouldnt let me. Would I be able to send via US mail to an adress or p.O. Box?
If you find/hear anything else about this prob. I'm
having, if you could lemme know but I promise to get a donation out.
Was this
answer
helpful?
Yes
No
Wednesday, March 12th, 2008 AT 11:31 AM
Tiny
SERVICE WRITER
  • EXPERT
2Carpros. Com INC.
341 W. Whittier Blvd
La habra, CA. 90631

Make sure you put your username on the check so you get denoted.

Thnak-you very much!
Was this
answer
helpful?
Yes
No
Wednesday, March 12th, 2008 AT 5:22 PM
Tiny
GUITAR42
  • MEMBER
O.K, will do.
Was this
answer
helpful?
Yes
No
Wednesday, March 12th, 2008 AT 6:34 PM
Tiny
HOLLYWOOD COLE
  • MEMBER
My dome light will not shut off. It just started happening 3 days ago. It would stay one for a while intermittently or just come on for no reason while I was driving down the road. I would hear a ding and then the light would come on.

Are you saying spray the latch assy. On the door with WD-40 and this might solve the problem?
Was this
answer
helpful?
Yes
No
Wednesday, March 11th, 2009 AT 9:44 AM
Tiny
JSINCL
  • MEMBER
SIMILAR PROBLEMS TO YOURS, REQUIRED NEW GEM CHIP/BOARD AND RESETTING BY PRO WHO CHARGED A FORTUNE
Was this
answer
helpful?
Yes
No
Wednesday, April 29th, 2009 AT 10:51 PM

Please login or register to post a reply.

Recommended Guides