1995 Mustang V6 SVT A/C Not Working

Tiny
CHARLES27
  • MEMBER
  • 1995 FORD MUSTANG
Ive been driving my car in this California heat and using the A/C pretty regularly. Yesterday I used the A/C and it worked fine when I left my car for about an hour and came back I turned the A/C on and nothing but hot air blew out. Ive noticed that I dont get the normal strain on the engine when I activate my A/C. Does this automatically mean my compressor clutch is bad? Or could I have lost my refrigerant to a leak somewhere in the system?
Do you
have the same problem?
Yes
No
Tuesday, August 1st, 2006 AT 2:48 PM

3 Replies

Tiny
TAURUSWHEEL
  • MEMBER
I would pull the elctrical connector off of the pressure switch, located on the low pressure side, usually on the receiver dryer unit, and jump the terminals on the plug and watch the a c compressor clutch to see if it locks up, if yes at least you know that works, second may be to get the system pressure tested, run the jumper only long enough to see if the clutch locks up
Was this
answer
helpful?
Yes
No
Tuesday, August 1st, 2006 AT 7:27 PM
Tiny
CHARLES27
  • MEMBER
Thanks for the advice. I went out and statred the car turned the A/C on and notcied my clutch was not engaging. I jumpered the pressure switch which was on the receiver unit and still the clutch didnt engage so my clutch assembly must be bad.
Was this
answer
helpful?
Yes
No
Thursday, August 3rd, 2006 AT 3:51 PM
Tiny
TAURUSWHEEL
  • MEMBER
Check all electrical connections to make sure they're still hooked up, could be a relay possibly. Might pay to have it looked at by qualified repair shop before dumping money if you're not 100%.
Was this
answer
helpful?
Yes
No
Thursday, August 3rd, 2006 AT 10:04 PM

Please login or register to post a reply.

Recommended Guides