1994 Ford Explorer coolant loss

Tiny
LILJERRY67
  • MEMBER
  • 1994 FORD EXPLORER
  • 6 CYL
  • 2WD
  • AUTOMATIC
  • 100,000 MILES
Last night I went to the grocery store about 2 miles from my home. Stopped at the gas station on the way back. There, coolant was POURING from the front of the engine compartment. I was a block from home so I went there. Coolant continued to pour out from no visiable area. Neither hose was leaking. It seemed to be coming from above the heater line coming off the pump. With the engine running I toped off the radiater and it runs cool now without any leaks. Drove a half mile this morning the gauge only rose slightly when acelerating. Still no leak let alone pouring out.
Do you
have the same problem?
Yes
No
Friday, April 9th, 2010 AT 8:33 AM

3 Replies

Tiny
JACOBANDNICKOLAS
  • EXPERT
Could it have been coming from the intake manifold or the water pump?
Was this
answer
helpful?
Yes
No
Friday, April 9th, 2010 AT 9:22 AM
Tiny
LILJERRY67
  • MEMBER
I put 20 miles on it today. The temp gauged spiked about half way twice and returned to normal both times. Im inclined to believe that the thermostat got stuck and the radiator boiled over. Ill replace the thermostat.
Was this
answer
helpful?
Yes
No
Friday, April 9th, 2010 AT 10:42 AM
Tiny
JACOBANDNICKOLAS
  • EXPERT
That could be the problem. It is cheap to try. Let me know what you find.

Joe
Was this
answer
helpful?
Yes
No
Friday, April 9th, 2010 AT 11:47 AM

Please login or register to post a reply.

Recommended Guides