1995 Ford Escort FAN WON'T TURN ON

Tiny
PUGSLEYPUTTS
  • MEMBER
  • 1995 FORD ESCORT
Engine Cooling problem
1995 Ford Escort 4 cyl Front Wheel Drive

I JUST REPLACED THE HEAD ON MY ESCORT. THE FAN WORKED BEFORE I STARTED, BUT IT DOESN'T NOW. ANY SUGGESTIONS?
Do you
have the same problem?
Yes
No
Monday, July 28th, 2008 AT 8:34 PM

3 Replies

Tiny
MUSTANG87
  • MEMBER
Check that the fan motor is working remove it and direct power it to see if it starts. Check connections on metal temp switch maybe u didnt connected. Also check fan control relay.U can get theses parts at a self serve junkyard just to seek problem and save money thats what I do.U can see what these parts look like here kragen. Com good luck
Was this
answer
helpful?
Yes
No
Monday, July 28th, 2008 AT 10:08 PM
Tiny
PUGSLEYPUTTS
  • MEMBER
Where is the fan control relay? Thank You
Was this
answer
helpful?
Yes
No
+1
Monday, July 28th, 2008 AT 10:58 PM
Tiny
MUSTANG87
  • MEMBER
Im not to sure on that car but possibly on front around radiator area bottom or on top or in front of trans cool radiator.U can also ask in a parts store they can find out. If you know what it looks like look for it around there or even somewhere else. Im sure youll find it.O by the way have you checked the fuses for the fan?Maybe has burnt. Check on fuse box under dash or sometimes has 2 fuse box one on engine comparment near fender. Hey try this. Turn on your motor and then turn on the ac your fan should come on if it good. If not then check all I said. Good luck
Was this
answer
helpful?
Yes
No
Monday, July 28th, 2008 AT 11:53 PM

Please login or register to post a reply.

Recommended Guides