Electrical issues start when all of the gauges stopped working

Tiny
DANIELSLIFE13
  • MEMBER
  • 2003 CHEVROLET 1500
  • 4.8L
  • V8
  • 2WD
  • AUTOMATIC
  • 250,000 MILES
All my gauges quit working. We tested all the fuses unplugged wiring harness plug it back in and everything started working. Now you turn on the left turn signal and step on the brake it blinks really fast and the cruise control quits working. Let your foot off the brake the blinker blinks fine cruise control can be reset. Now the gauges have quit again. What is my problem.
Do you
have the same problem?
Yes
No
Tuesday, June 25th, 2019 AT 5:27 PM

3 Replies

Tiny
KEN
  • ADMIN
Hello,

It sounds like you have a fuse out on the BCM. To be sure lets use this guide to check for power using this guide and the BCM location below:

https://www.2carpros.com/articles/how-to-check-a-car-fuse

Check out the diagrams (below). Please let us know what you find. We are interested to see what it is.
Was this
answer
helpful?
Yes
No
Thursday, June 27th, 2019 AT 11:12 AM
Tiny
DANIELSLIFE13
  • MEMBER
We checked all fuses that we could. There are black ones that are factory with no viewing port. All checked good. Is there a fuse on the BCM? The gauges are now working but the left turn signal still blinks fast with foot on the brake, blinks normal without brake pressed. Cruise still will shut off if engaged when left signal is turned on, but has no affect on right signal
Was this
answer
helpful?
Yes
No
Saturday, June 29th, 2019 AT 4:37 PM
Tiny
KEN
  • ADMIN
Yes there are fuses on the BCM I would check those first.
Was this
answer
helpful?
Yes
No
Saturday, June 29th, 2019 AT 4:37 PM

Please login or register to post a reply.

Sponsored links