Electrical issues?

Tiny
ANDREWDUMONT
  • MEMBER
  • 1999 CADILLAC DEVILLE
  • 4.2L
  • V8
  • 2WD
  • AUTOMATIC
  • 115,000 MILES
I went to start my car. I had just previously driven it maybe an hour beforehand and when I went to start it, I had power and my dash cluster lights, headlamps, radio turned on, but after about 5 seconds it would just shut off all electrical out. If I try to turn it over as soon as I did I'd hear one click and no electric throughout the entire vehicle until I opened up a door then it would let me try to crank it over again with the same result I thought it was my starter which is a pain I got down to the starter and the positive going to the starter was pretty loose so I tighten that back up put everything back together and I'm still having the same problem when I turn it over I hear one click and then nothing no electrical or anything.
Do you
have the same problem?
Yes
No
Sunday, December 4th, 2022 AT 1:18 PM

1 Reply

Tiny
JACOBANDNICKOLAS
  • EXPERT
Hi,

It sounds like you have a weak connection at some point. Are the battery terminals clean and tight, free of corrosion? Have you checked the ground wire from the battery to the engine block and body?

Take a look through this link and let me know if it helps:

https://www.2carpros.com/articles/everything-goes-dead-when-engine-is-cranked

Take care and let me know what you find.

Joe
Was this
answer
helpful?
Yes
No
Sunday, December 4th, 2022 AT 9:18 PM

Please login or register to post a reply.

Sponsored links