Eco mode not working properly

Tiny
SJDAILEY
  • MEMBER
  • 2016 TOYOTA COROLLA
  • 1.8L
  • 4 CYL
  • 2WD
  • AUTOMATIC
  • 53,000 MILES
The eco mode quit working on my Corolla S Plus. I had to get a new battery, and as soon as I connected the new battery the Eco mode began working again. However, after about 2 days of driving it the Eco mode turned off again. I tried cleaning the battery terminals, I checked to make sure the Eco feature was on, on the dash. I unhooked the battery and then hooked it back up and the eco light is still off. Not sure what to do or where to go from here, I have found no help online.
Do you
have the same problem?
Yes
No
Friday, September 24th, 2021 AT 11:34 AM

1 Reply

Tiny
JACOBANDNICKOLAS
  • EXPERT
Hi,

The eco mode on this vehicle regulates the air conditioning, heated seats, and other instruments that use power in your vehicle. By reducing the amount of power being used, it eliminates some of the load from the engine and helps improve fuel economy.

The eco mode is controlled by an AC amplifier. It is located under the dash on the driver's side. I attached pics below. Make sure the connection to it is in good condition. Also, let me know if the AC is working. If it isn't, check the heater IG fuse in the fuse box under the dash. It is a 10 amp fuse.

If the fuse is good, confirm there is power to and from it.

https://www.2carpros.com/articles/how-to-check-a-car-fuse

Let me know what you find or if you have other questions.

Take care,

Joe

See pics below.
Was this
answer
helpful?
Yes
No
+1
Friday, September 24th, 2021 AT 7:53 PM

Please login or register to post a reply.

Sponsored links