2002 Dodge Ram need help please

Tiny
SHADOWBOXER3764
  • MEMBER
  • 2002 DODGE RAM
  • V8
  • 2WD
  • AUTOMATIC
  • 130,000 MILES
Yesturday morning the truck was running fine, yesturday afternoon I was going up a hill, the truck downshifted into passing gear and at apx 4000 rpm started surging as if it was flooding out. Once I reached the top of the hill it upshifted and ran fine, I got the truck over 100mph. But everytime I punch the accelerator on a hill or flat it downshifts into passing gear it surges and hops at apx 400 rpm and will not build speed. Also I can shift to nuteral and rev the engine, but at apx 4000 rpm it surges as if its flooding out, could this be the fuel pump is going bad, or bad gas, possibly throttlle body?
Thanks
Do you
have the same problem?
Yes
No
Sunday, August 2nd, 2009 AT 9:56 AM

5 Replies

Tiny
JACOBANDNICKOLAS
  • EXPERT
I would start where you said, the fuel pump, unless the check engine light came on. Let me know if it did. Also, CHeck to make sure the catylatic converter isn't plugging. You may hear a hissing noise or rattle near it with the engine running. I have seen them glowing red hot. You can also check to make sure the back pressure seems normal at the tail pipe.

Here is a how to for checking fuel pump pressure. It's not hard to do. You may also want to try replacing the fuel filter if it hasn't been done for some time..

http://www.2carpros.com/how_to/how_to_check_fuel_pressure.htm
Was this
answer
helpful?
Yes
No
Sunday, August 2nd, 2009 AT 3:54 PM
Tiny
SHADOWBOXER3764
  • MEMBER
After I posted the previous question the truck was running fine, so out of sight out of mind thing. UNTIL the other day, I had the air conditioner on and the truck started doing the same thing. (At 4000 rpm it jumps and shudders)
Soooooooo I have driven it the past week without the a/c on and I am not having the problem. What can it be?
Thanks
Was this
answer
helpful?
Yes
No
Wednesday, August 26th, 2009 AT 7:53 PM
Tiny
JACOBANDNICKOLAS
  • EXPERT
Have you checked the things that I mentiond?
Was this
answer
helpful?
Yes
No
Wednesday, August 26th, 2009 AT 8:13 PM
Tiny
SHADOWBOXER3764
  • MEMBER
I had the cat converter checked, its fine. I tested the fuel pressure and its fine. As I stated, it ONLY happens AFTER I have been running the A/C.
It stays that way until after a few hours. Also as stated, I have been driving the truck for a week now without the A/C and it has had no problems at all.
Thanks
Was this
answer
helpful?
Yes
No
Wednesday, August 26th, 2009 AT 8:17 PM
Tiny
SHADOWBOXER3764
  • MEMBER
No idiot lights on the inst cluster have come on
Was this
answer
helpful?
Yes
No
Wednesday, August 26th, 2009 AT 8:18 PM

Please login or register to post a reply.

Recommended Guides