1988 Dodge Omni car won't start. Nothing works

Tiny
AIRLU
  • MEMBER
  • 3 POSTS
  • 1988 DODGE OMNI

Engine Mechanical problem
1988 Dodge Omni 4 cyl Two Wheel Drive Automatic 77000 miles

I started car this morning and everything was fine. Then the check engine light came on, so I immediately shut off the car. When I try to restart, nothing works. No power to the car what so ever. I check the battery and alternator, but they all both fine. What ever could it possibly be? Please help!

Do you
have the same problem?
Yes
No
Thursday, July 17th, 2008 AT 4:27 PM

5 Replies

Tiny
RASMATAZ
  • MEMBER
  • 77,156 POSTS

Inspect and test all fusible links-do you see all the idiot lights that normally comes on when key at run?

Was this
answer
helpful?
Yes
No
Thursday, July 17th, 2008 AT 4:33 PM
Tiny
AIRLU
  • MEMBER
  • 3 POSTS

No dash/gauge lights come on. No interior light and no headlights when I turn it on. Basically no power at all. I can not figure out what could be.

Was this
answer
helpful?
Yes
No
Thursday, July 17th, 2008 AT 4:38 PM
Tiny
RASMATAZ
  • MEMBER
  • 77,156 POSTS

Test the battery and connections and folow it by checking the fusible link/s

Was this
answer
helpful?
Yes
No
Thursday, July 17th, 2008 AT 4:46 PM
Tiny
AIRLU
  • MEMBER
  • 3 POSTS

Problem solved! Thanks.

Was this
answer
helpful?
Yes
No
Thursday, July 17th, 2008 AT 7:45 PM
Tiny
RASMATAZ
  • MEMBER
  • 77,156 POSTS

What was it? So that people with the same vehicle and problem will learn from it-

Was this
answer
helpful?
Yes
No
Thursday, July 17th, 2008 AT 8:07 PM

Please login or register to post a reply.

Recommended Guides