Vehicle speed

Tiny
JAVILA
  • MEMBER
  • DODGE CARAVAN
1997 Dodge Grand Caravan 3.0 L automatic 2 wheel
with 77000 miles: I have recently replaced the transmission in this van. As soon as I started driving it again it has given me more trouble it gave me 2 trouble codes P0500 and P0740 and the speedometer does not work in drive but does work in reverse. I have replaced the vehicle speed sensor located in the tranmission. No luck speedometer still does work the transmission is shifting but once in a while when taking off the van does not want to accerate even when my foot is to the floor. When this happen it has a lack time of at least a minute or less to accerrate but the transmission is shifting. I have had various diagnostic testing and the same codes keep coming up. Any suggestions
Do you
have the same problem?
Yes
No
Thursday, July 19th, 2007 AT 2:14 PM

3 Replies

Tiny
RASMATAZ
  • MEMBER
Try disconnecting the torque converter clutch solenoid at tranny and see what happens.
Was this
answer
helpful?
Yes
No
Saturday, July 21st, 2007 AT 12:03 AM
Tiny
JAVILA
  • MEMBER
Try disconnecting the torque converter clutch solenoid at tranny and see what happens.[/Quote:7e39ed076e]

No change speedometer still not working
Was this
answer
helpful?
Yes
No
Saturday, July 21st, 2007 AT 12:57 PM
Tiny
RASMATAZ
  • MEMBER
Now we go to the coolant temperature for lock-up and throttle position sensor for throttle pressure, could have another VSS on the dash ( combination meter ) that the computer is not receiving the proper signal.

Fluid and filter change?

You might want to have it pressure tested-to ID internal problems.
Was this
answer
helpful?
Yes
No
Saturday, July 21st, 2007 AT 3:19 PM

Please login or register to post a reply.

Recommended Guides