Is this my alternator or my battery

Tiny
NATHAN DITZEL
  • MEMBER
  • 2014 VOLKSWAGEN POLO
  • 1.4L
  • TURBO
  • 2WD
  • MANUAL
  • 92,000 MILES
Some more detail, I have a UK 64 Reg VW Polo (2014) which has 90,000 miles on the clock. Whilst driving an error came up showing “12v battery not charging” this has come up before and gone away the same journey so I assumed the same, after a little while I got an error saying that the ABS has stopped working, then that the tire pressure indicator isn’t working, and more and more lights kept showing up on my dash. Eventually I had no power steering, my whole radio interface had gone off, but the engine, gears and brakes were all still fine. I was very close to home so I decided to make it back, and on the last turn my steering locked up completely, I was able to make it round one bend and into my drive extremely luckily. Is this a Battery Fault or an Alternator fault, or am I just going to have to get this checked at a garage?
Do you
have the same problem?
Yes
No
Tuesday, June 18th, 2019 AT 4:27 AM

1 Reply

Tiny
SCGRANTURISMO
  • EXPERT
Hello,

This sounds to me like it's your vehicle's alternator that is failing, or has failed. The battery in your vehicle is generally used to start your vehicle and the alternator is used to power the vehicle while it is running as well as charge the battery. Here are a few links to go to down below:

https://www.2carpros.com/articles/how-to-check-a-car-alternator
https://www.2carpros.com/articles/how-to-jump-start-car-battery-using-jumper-cables
https://www.2carpros.com/articles/car-battery-load-test

Please go through these guides and then get back to us with how things turn out.

Thanks,
Alex
2CarPros
Was this
answer
helpful?
Yes
No
Tuesday, June 18th, 2019 AT 5:03 AM

Please login or register to post a reply.

Sponsored links