Dashboard lights not working properly

Tiny
MARSHAL MANYANGA
  • MEMBER
  • 2002 PEUGEOT 406
  • 2.0L
  • 4 CYL
  • 2WD
  • MANUAL
  • 71,000 MILES
The car is not showing lights on the dashboard when I switch on at the start position before cranking. The lights will come after cranking.
Do you
have the same problem?
Yes
No
Wednesday, September 29th, 2021 AT 1:23 AM

7 Replies

Tiny
JACOBANDNICKOLAS
  • EXPERT
Hi,

This vehicle isn't offered in the US, but I will try my best to help.

I need some general information. First, is the vehicle running properly other than this issue? Have you noticed any other electrical components not working properly? Does the check engine light turn on or anything with the key in the run position and the engine off (before starting)?

Let me know.

Take care,

Joe
Was this
answer
helpful?
Yes
No
Wednesday, September 29th, 2021 AT 7:46 PM
Tiny
MARSHAL MANYANGA
  • MEMBER
There are no lights coming out neither engine check light, battery, and any other when the key is on accessories. The engine check light will only show when the engine starts only and disappears. Note: when the engine is running the cluster lights will appear as soon as you switch off to accessories no lights appear on the cluster i.E. Battery or engine check light.
Was this
answer
helpful?
Yes
No
Wednesday, September 29th, 2021 AT 11:04 PM
Tiny
JACOBANDNICKOLAS
  • EXPERT
Hi,

When you say accessory mode, are you referring to the run position? In the accessory mode, most vehicles' indicators don't come on in accessory mode.

Please confirm.

Thanks,

Joe
Was this
answer
helpful?
Yes
No
Thursday, September 30th, 2021 AT 6:11 PM
Tiny
MARSHAL MANYANGA
  • MEMBER
I mean it used to show everything battery, engine check light on accessory position before you kick start the engine.
Was this
answer
helpful?
Yes
No
Thursday, September 30th, 2021 AT 9:51 PM
Tiny
JACOBANDNICKOLAS
  • EXPERT
Hi,

Okay, if they used to come on and don't now, have you checked fuses? if you have and they are good, did you confirm there is power to and from them? A fuse can be good but not have power available. Here is a link that shows what I mean.

https://www.2carpros.com/articles/how-to-check-a-car-fuse

Also, the problem could be related to a poor connection at the instrument panel or even an issue with the ignition switch. I don't have wiring schematics to point you to a specific wire but check under the dash to make sure nothing is loose.

Let me know.

Joe
Was this
answer
helpful?
Yes
No
Friday, October 1st, 2021 AT 7:08 PM
Tiny
MARSHAL MANYANGA
  • MEMBER
Thank you very much. I checked the connections under the steering fuse box and eventually it starts working I think there was loose connection but didn't notice which wire exactly.
Was this
answer
helpful?
Yes
No
Friday, October 1st, 2021 AT 11:48 PM
Tiny
JACOBANDNICKOLAS
  • EXPERT
Hi,

It sounds like you are on the right track. Inspect the connections. Make sure there are no fuse connectors that are corroded or pushed in causing a poor connection.

If possible, take a pic of where you were working when it started working and upload it for me to see. Hopefully, I'll notice a potential issue.

Take care,

Joe
Was this
answer
helpful?
Yes
No
Saturday, October 2nd, 2021 AT 6:26 PM

Please login or register to post a reply.

Sponsored links