Crank but no start

Tiny
HALINVER
  • MEMBER
  • 1991 DODGE DAKOTA
  • 3.9L
  • V6
  • 2WD
  • MANUAL
  • 97,118 MILES
The pick up was just overhauld and a week after just shut down and never started again. Changed every sensor, pick up coil, checked every splice connections and continuity and everything is alright, fuel pump works fine. Replaced the pcm. But doesnt start. It just dont give signal to the sensors. Dont know what else to do.
Do you
have the same problem?
Yes
No
Monday, March 28th, 2016 AT 11:22 AM

11 Replies

Tiny
HMAC300
  • EXPERT
Check your asd relay under hood first it may be corroded or making bad contact. Then check all fuses as you mayhave blown one going to ecm
Was this
answer
helpful?
Yes
No
Monday, March 28th, 2016 AT 12:07 PM
Tiny
HALINVER
  • MEMBER
Thanks for yout replay. Have done that already. Everything is fine. Tried bypass the asd and the fuel pump will start working but the car still wont start. It gets no spark. But the coil and everything is new. Dont know what else to do.
Was this
answer
helpful?
Yes
No
Monday, March 28th, 2016 AT 12:25 PM
Tiny
HMAC300
  • EXPERT
Check fuse D in pdc and fuse 13 in truck as they both power asd relay and may be killing power to the ecm. Other than that I can't think of anything else. If you get power from coil wire to dist then it may be a rotor/dist cap. Also check ohms of pick up coil in dist.
Was this
answer
helpful?
Yes
No
Monday, March 28th, 2016 AT 1:04 PM
Tiny
HALINVER
  • MEMBER
Can you tell me please where are they located? Cant fine fuse D and fuse 13z
Was this
answer
helpful?
Yes
No
Monday, March 28th, 2016 AT 1:53 PM
Tiny
HALINVER
  • MEMBER
Coil, Dist cap and pick up coil in dist are new. But cant get spark. The wire that give energy to the ecm pin 3 is good but the pcm does not give signal to the sensors.
Was this
answer
helpful?
Yes
No
Monday, March 28th, 2016 AT 2:01 PM
Tiny
HMAC300
  • EXPERT
I did tell you the fues d is in Pdc-power dist center under hood and 13 is inside the truck I have no pic of pdc so you'll have to physically look
Was this
answer
helpful?
Yes
No
Monday, March 28th, 2016 AT 3:08 PM
Tiny
HMAC300
  • EXPERT
See pic
Was this
answer
helpful?
Yes
No
Monday, March 28th, 2016 AT 3:08 PM
Tiny
HALINVER
  • MEMBER
Checked the Fuse D and 13 but the are good, cheked every splice and wire continuity and everything is good. What els you recommend me to do?
Was this
answer
helpful?
Yes
No
Tuesday, March 29th, 2016 AT 12:28 PM
Tiny
HMAC300
  • EXPERT
I have no further suggestions or comments unless it's an ignition switch problem.
Was this
answer
helpful?
Yes
No
Tuesday, March 29th, 2016 AT 1:20 PM
Tiny
HALINVER
  • MEMBER
Ok, I have checked the ignition switch and it seems to be working fine but I will change it anyway thank you for the suggestion.
While checking the dash lights the left side of the dashboard does not work. Only the oil light turn on when I switch on the car and while cranking it turn off. The right signal light works too. But the left one does not, the check engine light, headlights light, handbrake does not work either. That means there is a wiring problem right?
Was this
answer
helpful?
Yes
No
Thursday, March 31st, 2016 AT 4:34 AM
Tiny
HMAC300
  • EXPERT
More than likely or something has been changed from incorrect year
Was this
answer
helpful?
Yes
No
Thursday, March 31st, 2016 AT 6:10 AM

Please login or register to post a reply.

Recommended Guides