Climate control not working properly

Tiny
RUDYPAK
  • MEMBER
  • 2005 TOYOTA SIENNA
  • 3.3L
  • 6 CYL
  • 2WD
  • AUTOMATIC
  • 222,000 MILES
Last year the blend gate on the front passenger side stopped working. I had cold air all the time. I had noticed a clicking sound but ignored since everything was working and I was unfamiliar with the system. That was until my wife complained about her feet being so cold all the time any time we went somewhere.
Thanks to people like 2CarPros it pointed me in the right direction and I fixed it.
So my van listed above XLE model has the dual climate control and recently I have heard that same clicking noise in the rear. When I adjust the temperature control for the rear up and down at some point it stops.
Is there a blend gate for the rear?
Do you
have the same problem?
Yes
No
Saturday, August 1st, 2020 AT 8:27 PM

3 Replies

Tiny
JACOBANDNICKOLAS
  • EXPERT
Hi,

It does have one. I attached a pic of location below for you to see. Here is a link that shows in general how one is replaced:

https://www.2carpros.com/articles/replace-blend-door-motor

Let me know if this helps.

Joe
Was this
answer
helpful?
Yes
No
Sunday, August 2nd, 2020 AT 12:12 AM
Tiny
RUDYPAK
  • MEMBER
Definitely helps. Thank you.
Was this
answer
helpful?
Yes
No
Sunday, August 2nd, 2020 AT 8:28 AM
Tiny
JACOBANDNICKOLAS
  • EXPERT
Happy to help. Let us know if you have questions in the future.

Take care,
Joe
Was this
answer
helpful?
Yes
No
Sunday, August 2nd, 2020 AT 8:35 PM

Please login or register to post a reply.

Sponsored links