2003 Chrysler PT Cruiser Turn Signals not functioning - NOT

Tiny
HOOTIEMOMMA
  • MEMBER
  • 2003 CHRYSLER PT CRUISER
Electrical problem
2003 Chrysler PT Cruiser Automatic 94000 miles

Sometime in February 2009, my turn signals stopped working. When I moved the turn signal to indicate right or left turn, nothing happened at all.
I took the car to a shop I trust in Overland Park, KS. Not the dealer just a shop I trust. I was informed that I needed a new multifunction switch. They installed it and when I picked the car up, the mechanic had drawn me a picture and explained that if I turn the Hazards on, the turn signals will not work. It will cause it to malfunction again.
August 2010, I was cleaning my car and I barely depressed on the Hazards. I knew what I had done the moment I did it. So of course, the turn signals stopped working and the Hazards do not work either. [But I don't miss the Hazards because I haven't used them in 18months.]
I took the car back to the shop I trust. They did not know what mechanic had worked on my car and they did not have the picture he drew. [It had been a year and a half so I’m not mad or anything about this, it’s just a bummer.] They somehow (i have no clue how) determined that I needed another multifunction switch and a flasher. They quoted me almost $400 to do this.
I don’t have a lot of extra money. So I went to the Chrysler dealer and purchased a new multifunction switch. I got on-line and figured out how to do it myself. I took off the multifunction switch and installed the new one. No change.
Then I went down to O’Reilly’s and bought a new flasher, 12 Volt Five prong thing. No change. Returned that flasher and got my $20 back.
I checked all the fuses under the hood and under the dash. I checked all the bulbs on the car to make sure a bulb wasn’t burnt out.
Went home, uninstalled the new Multifunction switch and took that back to the dealer and was refunded 100% of my money!
So I have eliminated several things but I am still at a loss for what it could be. The "multifunction swithc" operates the lights, the fog lights, the turn signals and hazards. Half of it is not operating properly, turn signals and hazards.
Any suggestions? Thanks in advance for reading this and looking into it for me!
Do you
have the same problem?
Yes
No
Monday, August 16th, 2010 AT 9:41 AM

3 Replies

Tiny
KEN
  • ADMIN
Sorry for the delayed responce. It sounds like you might have blown one of the fuses that power up that system. We will need to start there. Here is the wiring diagram for your car. test the power input at the switch and get back to me please.


http://www.2carpros.com/forum/automotive_pictures/10_wiring_3.jpg



Enlarge your screen size to see the diagram (ctrl + )

Thanks for using 2Carpros.com
Was this
answer
helpful?
Yes
No
Wednesday, August 18th, 2010 AT 6:02 PM
Tiny
HOOTIEMOMMA
  • MEMBER
I stated that in my original message. I think it's something to do with the wiring.
Was this
answer
helpful?
Yes
No
+1
Thursday, August 19th, 2010 AT 8:44 AM
Tiny
KHLOW2008
  • EXPERT
Hi hootiemomma,

It is possible to be a wiring fault so get a test lamp and we can start some diagnostic testings.

When testing, probe the terminals indicated with the test lamp attached to a good ground.

Perform the following test at the multifunction switch.

With ignition OFF.
Is there battery voltage at terminal # 11 ( Pink/Dark Green wire)?

With ignition ON.
Is there battery voltage at terminal # 3 ( Red/White wire)?

I am stumped why the mechanic mentioned to you the flasher would not work if the hazard is used. The only explanation that I can come up with is the type of flasher unit used. Is the correct flasher unit installed?

Flasher relays are not universal and if the wrong terminal locations are used, they would not function correctly.

I am not sure of the flasher terminal locations as the wiring diagram does not indicate them. Would it be possible to upload a picture of the flasher relay terminals and the multifunction switch relay terminals with the relay unplugged?

With some testing, we can determine if the relay and terminals match up.
Was this
answer
helpful?
Yes
No
-2
Saturday, August 21st, 2010 AT 9:34 AM

Please login or register to post a reply.

Recommended Guides