2001 Chrysler Grand Voyager Air Conditioning not working

Tiny
DALEFROM NJ
  • MEMBER
  • 2001 CHRYSLER GRAND VOYAGER
  • 6 CYL
  • FWD
  • AUTOMATIC
  • 88,000 MILES
My wife and I bought our Voyager about six months ago and the AC was intermittenly locking up and breaking the serpentine belt. We took it to a local garage and they put an AC compressor kit on it which costed us $1,050.00 including labor. The problem we are having now is that when it gets Hot outside, the AC stops working and it only blows warm air. It works fine otherwise. We took it back to the garage not long after they did repairs, and "I think" they said the compressor actually was not getting power at certain times. We didnt have time for them to troubleshoot it further because we needed the car back. I really hope they dont tell us we need to dump a lot more money into it after they put this kit on it which should cover all the major parts! Any insight and replys would be greatly appreciated.
Do you
have the same problem?
Yes
No
Friday, June 4th, 2010 AT 10:00 PM

1 Reply

Tiny
DALEFROM NJ
  • MEMBER
Here's an update to my original post. I was told that the PCM is not sending the ground to the compressor at certain times (it seems temperature related) so I was told the only solution would be to replace the PCM. I was hoping it might be a simple relay because as long as the car is in motion going down the road, the Air works fine, but if I come to a stop for even 5 seconds, the blower will start blowing only warm air until I restart the car, AND turn on the ac while in motion. If the daytime temps are above 75 or 80, the AC acts up everytime! Does that sound like a PCM problem?
Was this
answer
helpful?
Yes
No
Monday, August 23rd, 2010 AT 8:15 PM

Please login or register to post a reply.

Recommended Guides