NO SPEEDOMETER,FULL GAUAGE, NO

2000 Chrysler Grand Voyager

Tiny

jasonj70

October, 28, 2009 AT 2:09 PM

Where is this fuses box located there are 2 of them. I could not see the diagram well enough too small.
Is there somewhere we can see a bigger diagram?

Tiny

Docfixit

October, 28, 2009 AT 2:21 PM


http://www.2carpros.com/forum/automotive_pictures/198357_Graphic_222.jpg

Tiny

jasonj70

October, 28, 2009 AT 2:47 PM

All the fuses in the fuse box are good. Tested them with a test lite. Could it be a relay?

Tiny

Docfixit

October, 28, 2009 AT 2:55 PM

Having trouble locating another fuse box. There is one under instrument panel?
Seems a change was made in model year what is production date?

Tiny

jasonj70

October, 28, 2009 AT 3:57 PM

The production date is 4/99

Tiny

jasonj70

October, 29, 2009 AT 6:30 AM

I have had the fly wheel replaced also.

Tiny

Docfixit

October, 29, 2009 AT 12:17 PM

In junction panel under left side dash check fuse #2 a 10 amp. Is PRNDL light out?

Tiny

jasonj70

October, 30, 2009 AT 7:13 AM

Yes the lite is out and the odemeter is too.

Tiny

jasonj70

October, 30, 2009 AT 12:05 PM

ALL THE FUSES ARE GOOD IN BOTH FUSE BOXES; UNDER THE DASH AND UNDER THE HOOD ON THE LEFT HAND SIDE.

Tiny

jasonj70

November, 2, 2009 AT 7:08 AM

No gauages work, the heater is stuck in defrost mode, no buttons work, on the heater panel.

Please login or register to post a reply.

Instrument Cluster Replacement GMC Yukon
Coolant Temperature Sender Replacement
Blend Door Actuator Replacement