2000 CHRYSLER GRAND VOYAGER NO SPEEDOMETER,FULL GAUAGE, NO

  • Tiny
  • Jasonj70
  • 2000 CHRYSLER GRAND VOYAGER

2000 Chrysler Grand Voyager 6 cyl

all my gauges on the cluster (speedometer, tach, fuel gauage, temp gauage, odemeter, and shift information) is gone. My abs light, service engine soon and air bag light are lite too. When it put on the computer it states that everything is good right. Can you help with this?

Do you
have the same problem?
Yes
No
Saturday, October 24th, 2009 AT 11:51 AM

20 Replies

  • Tiny
  • Docfixit
  • EXPERT
  • 18,990 POSTS

Hi
Have you checked fuse # 28 a 10 amp in underhood Power Distribution Center?
Let me know
Thanks for donate

Was this
answer
helpful?
Yes
No
Saturday, October 24th, 2009 AT 1:23 PM
  • Tiny
  • Jasonj70
  • MEMBER

All the fuses have been checked.

Was this
answer
helpful?
Yes
No
Saturday, October 24th, 2009 AT 1:50 PM
  • Tiny
  • Docfixit
  • EXPERT
  • 18,990 POSTS

Well then it's time to pull instrument panel out and test for voltage, grounds and printed cicuit board contiuity. Is this something your up to? If so do you have test light And digital volt ohm meter?

Was this
answer
helpful?
Yes
No
Saturday, October 24th, 2009 AT 2:00 PM
  • Tiny
  • Jasonj70
  • MEMBER

There is power and ground at the plug that plugs into the instrument panel.

Was this
answer
helpful?
Yes
No
Tuesday, October 27th, 2009 AT 8:53 AM
  • Tiny
  • Docfixit
  • EXPERT
  • 18,990 POSTS

Check these terminals
#2- pink-voltage
#6- orange- voltage
#7- black/light green- ground
#9- white/black- ground
#10- violet/brown- voltage
#11- red/white- voltage
#13- black- ground
test key on

Was this
answer
helpful?
Yes
No
Tuesday, October 27th, 2009 AT 9:11 AM
  • Tiny
  • Jasonj70
  • MEMBER

We took the speedo cluster out of this van and put in it a identical van and that works in there prefectly. Took bcm from the broken van and put in the other van and it work prefect in there also. We took the main computerfrom the broken van and put in the other van and it worked good in there. Took other body module under hood on right side of van, put in the good van and it worked fine in there, too.
There is no diagram for the fuses under dash. Where do we get something like that? The plug in up there as good grounds and powers are fine at that plugin. HELP! I WANT MY VAN BACK!

Was this
answer
helpful?
Yes
No
Wednesday, October 28th, 2009 AT 6:55 AM
  • Tiny
  • Docfixit
  • EXPERT
  • 18,990 POSTS

Are fuses numbered? If yes pull out check #24

Was this
answer
helpful?
Yes
No
+1
Wednesday, October 28th, 2009 AT 10:46 AM
  • Tiny
  • Jasonj70
  • MEMBER

I don't know if this would matter, but I just had the torquec converter replaced before this happened would that have anything to do with the problem?

Was this
answer
helpful?
Yes
No
Wednesday, October 28th, 2009 AT 12:04 PM
  • Tiny
  • Jasonj70
  • MEMBER

Where is this #24 located at under dash or under hood?

Was this
answer
helpful?
Yes
No
Wednesday, October 28th, 2009 AT 1:17 PM
  • Tiny
  • Docfixit
  • EXPERT
  • 18,990 POSTS


http://www.2carpros.com/forum/automotive_pictures/198357_Graphic_221.jpg

well it copied to small on bottom left second up in verticle position

Was this
answer
helpful?
Yes
No
Wednesday, October 28th, 2009 AT 1:36 PM

Please login or register to post a reply.

Other Instrument Cluster Gauge Speedometer Questions