1995 Chrysler Cirrus No Gauges, Milelage or PRNDL on dash.

Tiny
GANTECKI
  • MEMBER
  • 1995 CHRYSLER CIRRUS
  • 6 CYL
  • FWD
  • AUTOMATIC
  • 86,000 MILES
The problem that I am having is that the instrument cluster was working intermittently. The gauges worked and then stopped working. When the instrument cluster showed the mileage the car would start up and stay running. When the instrument cluster showed that 0 miles on the cluster and no gauges the car would start up and then stall out again. Now the car is saying 0 miles and will stay running. I have check the fuses and also tried retrieveing the trouble codes. When trying to retrieve the trouble codes it says no communication. What should I do from here?
Do you
have the same problem?
Yes
No
Friday, July 9th, 2010 AT 9:46 AM

7 Replies

Tiny
INTERNETMECHANIC
  • MEMBER
Did you check applicable fuse circuits for voltage? Did you use a scanner to check for codes or try the mil method? No luck either way? The fuses in the picture below are for the instrument cluster. My better database is down, can't track communication issue like I need to to. Thanks for donation.


http://www.2carpros.com/forum/automotive_pictures/512072_chrysler_cirrus_instrument_cluster_1.jpg

Was this
answer
helpful?
Yes
No
Friday, July 9th, 2010 AT 7:42 PM
Tiny
GANTECKI
  • MEMBER
I tried to check the codes with a scanner and it says no communication and the scanner can't scan for codes. Then I tried to check the codes using the Mil light and that doesnt work also. I checked all the fuses for power and they all check out like they should. Would a bad ECM be the problem? I'm really frustrated with this.
Was this
answer
helpful?
Yes
No
Friday, July 9th, 2010 AT 11:49 PM
Tiny
INTERNETMECHANIC
  • MEMBER
So the vehicle will start and run? In your first post about the sixth line down, you say the vehicle will stay running? Is that correct? I understand your frustration.
Was this
answer
helpful?
Yes
No
Saturday, July 10th, 2010 AT 9:48 AM
Tiny
GANTECKI
  • MEMBER
The vehicle will start up and stay running.
Was this
answer
helpful?
Yes
No
Saturday, July 10th, 2010 AT 11:08 PM
Tiny
INTERNETMECHANIC
  • MEMBER
I can show you my database procedure.


http://www.2carpros.com/forum/automotive_pictures/512072_instrument_cluster_no_response_1_1.jpg



http://www.2carpros.com/forum/automotive_pictures/512072_instrument_cluster_no_response_2_1.jpg

Was this
answer
helpful?
Yes
No
+1
Sunday, July 11th, 2010 AT 7:41 AM
Tiny
GANTECKI
  • MEMBER
All the gauges were working fine until the car would start up and then stall out. Also the mileage would show on the dash. Customer was never having any trouble with the gauges before this. The gauges all worked fine. I'm getting no communcation from the scan tool and can't retrieve any of the codes or access the computer. Is it likely that the computer has an internal problem or would you be leaning more towards a BCM?
Was this
answer
helpful?
Yes
No
Monday, July 12th, 2010 AT 10:58 AM
Tiny
INTERNETMECHANIC
  • MEMBER
My first thought was the bcm, about the instrument cluster. I don't know why you can't communicate with the computer?
Was this
answer
helpful?
Yes
No
-1
Monday, July 12th, 2010 AT 11:11 AM

Please login or register to post a reply.

Recommended Guides