No brake lights?

Tiny
UTHNKUNOME27
  • MEMBER
Ok I will try that tomorrow.
So the same big connector that the multi switch plugs came out of is the one that you are talking about that is behind the knee balaster?
Is it the green and yellow wire on the firewall side or seat side of the big connector?
I will take all that mess back off tomorrow. We are still driving it so I had to put it all back together.
Was this
answer
helpful?
Yes
No
Tuesday, January 12th, 2010 AT 1:14 PM
Tiny
JDL
  • EXPERT
Those wiring colors are two separate wires, under the dash, those wires are brake lite feed from the multifunction switch, for left and right brake lite at the rear. The high-mount brake lite is not wired through the multifunction switch. I didn't think the problem was in the multifunction switch, but, we can check circuits anyway.
Was this
answer
helpful?
Yes
No
Tuesday, January 12th, 2010 AT 2:40 PM
Tiny
UTHNKUNOME27
  • MEMBER
I was talking with my dad on the phone and he has been trying to help out with this also.
We were trying to figure out why no brake lights but have flashers.

The emergency flashers are the brake lights correct? Im not sure what would happen if I applied the brakes while the flashers are going. I havnt tried that yet.
Since the brake lights dont work but flashers do then the problem is definatly in the dash somewhere right? Am I kinda on the right track here. Haha.
Its 4:45am now so I will try to check some things when I wake up today if I have time.

Thanks for all the help so far.
Was this
answer
helpful?
Yes
No
Wednesday, January 13th, 2010 AT 3:44 AM
Tiny
JDL
  • EXPERT
I believe the problem is the feed to the multifunction switch from the brake lite switch. The feed from the brake lamp switch to the multifunction switch and the feed from the flasher to the multifunction switch are two different feed circuits. Have fun.
Was this
answer
helpful?
Yes
No
Wednesday, January 13th, 2010 AT 9:29 AM
Tiny
UTHNKUNOME27
  • MEMBER
I checked the green and yellow wire at the connector. No power to them when the brake is pressed in.

I still have cruise control and it will cut off like it supposed to when I press the brake.
Was this
answer
helpful?
Yes
No
Thursday, January 14th, 2010 AT 6:59 PM
Tiny
JDL
  • EXPERT
Check the white wire going to the connector for voltage with the brake switch activated. If there is more than one white wire, I don't know which one?

If no voltage on the proper white wire, brake activated, you'll have to backtrack the white wire. You could take the connector loose at both ends, make sure it is the correct circuit, do an ohms test, check for continuity, no continuity, there is an open circuit. All repair info says to disarm airbag, where applicable, when working under the dash.
Was this
answer
helpful?
Yes
No
Friday, January 15th, 2010 AT 9:47 AM
Tiny
UTHNKUNOME27
  • MEMBER
I've done some more digging today and I traced the white wire from the brake switch to a connector just above the steering shaft. I think this will cause it to mess up everytime. Im going to get a connector but I feel quite confident this is fixed. Thanks for all the help.
Was this
answer
helpful?
Yes
No
+1
Friday, January 15th, 2010 AT 2:54 PM
Tiny
JDL
  • EXPERT
Well, I hope you got it going your way. Goodluck
Was this
answer
helpful?
Yes
No
Friday, January 15th, 2010 AT 4:10 PM
Tiny
UTHNKUNOME27
  • MEMBER
It worked, Thanks for the help. Im back on the road again
Was this
answer
helpful?
Yes
No
Friday, January 15th, 2010 AT 4:21 PM
Tiny
UTHNKUNOME27
  • MEMBER
Well I spoke too soon. Ive ran into another issue.
When the headlights are in the off position all of the brake lights work fine. When the headlight switch is in the parking light or "on" position then only the upper and passenger side brake light works. Also the left blinker blinks really fast when the parking or headlights are on. Other wise the left and right blinker blinks fine.
When the headlights are on and I press the brake the whole drivers side tail light assembly goes out completely.

The left blinker issue happened before I found the broke wire yesterday. This, I guess, was an ongoing problem that my mom didnt tell me about.
What kind of issue am I looking at here.
Was this
answer
helpful?
Yes
No
Saturday, January 16th, 2010 AT 10:57 AM
Tiny
JDL
  • EXPERT
Sorry for the late come-back. Having trouble with e-mail. Yesterday, I didn't have any, today, I have 13 dating back to Saturday.

About your question, In an earlier post, I gave you the wiring colors to check at the steering column connector, for feed, to left and right brake lites. Check those feed wires for voltage when the problem is ongoing.
Was this
answer
helpful?
Yes
No
Tuesday, January 19th, 2010 AT 9:40 AM
Tiny
BERNIEM
  • MEMBER
I had an issue a while back. With my 99 Tahoe

No brake lights one day.
Did the wires thing. Noticed the light switch also.
Left will flash fast. Right wont. Or something weird.

I figured out the issue by accident.
I hope this helps. Im sure it will.

Step by step
Start the truck / Turn on lights to full.
Bring the steering wheel down using the
tilt, Then hit the left signal switch to stay down.
Then press down on the Hazard button/Switch.
Then turn if back off. See if there was any change.
PRESS HARD ON IT on the DOWN and jiggle on it and watch for it.

I had to break mine out to fix my issue.
I dont suggest to do this. But I had too. Lol

" Sometimes you have to break something to fix it. " Me
Was this
answer
helpful?
Yes
No
Wednesday, January 20th, 2010 AT 7:07 AM
Tiny
XPOCDUDE
  • MEMBER
  • 1998 CHEVROLET TAHOE
  • V8
  • 4WD
  • AUTOMATIC
  • 156,000 MILES
Hi there ive got a problem ive replaced the brake switch 3 times thinking they might of been bad, allso replaced the brake fuse, but still dont have any brake lights, they have allways worked till now what could I check or do to fix this problem. Thanks Jeff
Was this
answer
helpful?
Yes
No
Wednesday, December 23rd, 2020 AT 1:34 PM (Merged)
Tiny
RACEFAN966
  • EXPERT
Ok you have one of two problems here. Either the turn signal switch is bad or you have bad circuit boards in your tail lights. As long as there is not wiring problems or no one added a trailer light connector and did it wrong or something. Here is the taillight connector plate. If I was going to replace them to find out I would do one first as most parts stores will not take back electrical parts once pluged in.


https://www.2carpros.com/forum/automotive_pictures/249564_228062_1.jpg

Was this
answer
helpful?
Yes
No
Wednesday, December 23rd, 2020 AT 1:34 PM (Merged)
Tiny
XPOCDUDE
  • MEMBER
Hi you responded to me but I dont have turn signal problems.I have no brake lights ive replaced my brake light switch like 3 times just in case they were bad. An replaced the brake fuse allso but no brake lights still. What to check thanks jeff
Was this
answer
helpful?
Yes
No
Wednesday, December 23rd, 2020 AT 1:34 PM (Merged)
Tiny
RACEFAN966
  • EXPERT
Yes excatly I know what your problem is now please check the circuit boards (pictured in the previous response) in the taillights and still it could be a turn switch. See the turn signal switch is where all the power goes for the brake lights. The power goes through the turn switch then to the brake light light switch that is how the turn switch is able to interupt the brake light to make it blink when you use the turn signals. I hope this helps explain how it works. Get back to me as to what you find. To check the circuit board you may need an ohm meter if you can't find obvious signs of a short or burn on the board.
Was this
answer
helpful?
Yes
No
Wednesday, December 23rd, 2020 AT 1:34 PM (Merged)
Tiny
RACEFAN966
  • EXPERT
Oh yea one thing to check first do you have power going to the brake light switch?
Was this
answer
helpful?
Yes
No
Wednesday, December 23rd, 2020 AT 1:34 PM (Merged)
Tiny
XPOCDUDE
  • MEMBER
Thanks for your addvice, you were wright someone addeda trailer hitch an lights, when they did the just about cut through 2 wires in the harness, just enough so over time they came apart to the point were they were just barely makeing contact. I fix the 2 wires an the brakes work great thanks so much for your help. I will letting any one know about your site if they have any problems. Thanks again, Jeff
Was this
answer
helpful?
Yes
No
Wednesday, December 23rd, 2020 AT 1:34 PM (Merged)
Tiny
CSHERNANDEZ
  • MEMBER
  • 1998 CHEVROLET TAHOE
  • V8
  • 2WD
  • AUTOMATIC
  • 152,000 MILES
I hasve check fuses, replaced brake light switch, bulbs, bulb panel. Looking for brake relay, not in underhood / fuse relay box, any ideas? Where is multi-function relay/switch? No brake lights, not even LCD on top, will turn signal switch have anything to do with this problem?
Was this
answer
helpful?
Yes
No
Wednesday, December 23rd, 2020 AT 1:34 PM (Merged)
Tiny
RACEFAN966
  • EXPERT
Great glad to hear they are working again. Thanks for the support. It all of you that keep us going. Again thanks and have a great weekend.
Was this
answer
helpful?
Yes
No
Wednesday, December 23rd, 2020 AT 1:34 PM (Merged)

Please login or register to post a reply.

Sponsored links