1995 Chevy Tahoe No oil pressure indicated

Tiny
JIMMCCAIN
  • MEMBER
  • 1995 CHEVROLET TAHOE
  • V8
  • 2WD
  • AUTOMATIC
  • 220,000 MILES
Hello,

I recently changed the automatic transmission, and have not had oil pressure indicated since, although the engine runs fine and obviously actually DOES really have oil pressure.

Where is the oil pressure sensor located physically on this pre-vortec 5.7 V8 engine? I feel that it's only a wire disconnected, but so far I've not found the sending sensor. Of course, if the sensor has just coincidentally failed (unlikely) I'll still need to know where it is to replace it.

Regards,
Jim
Do you
have the same problem?
Yes
No
Wednesday, August 13th, 2008 AT 9:12 PM

4 Replies

Tiny
JIMMCCAIN
  • MEMBER
The sensor is not located near the filter, although there are several capped off connections nearby. This vehicle is fitted with what appears to be an oil cooling system going to the radiator and back, possibly part of a towing package. Are there any ports on the backside of the engine for oil pressure sensor? Remember that this problem started when the transmission was replaced.
Regards,
Jim
Was this
answer
helpful?
Yes
No
Thursday, August 14th, 2008 AT 5:37 PM
Tiny
JIMMCCAIN
  • MEMBER
[/quote:10996bdc0b]
Was this
answer
helpful?
Yes
No
Thursday, August 14th, 2008 AT 11:47 PM
Tiny
MERLIN2021
  • EXPERT


https://www.2carpros.com/forum/automotive_pictures/62217_ops_1.jpg


It's next to the distributor, location #8
Was this
answer
helpful?
Yes
No
+2
Friday, August 15th, 2008 AT 11:12 AM
Tiny
LEGITIMATE007
  • EXPERT
Your welcome
Was this
answer
helpful?
Yes
No
Friday, August 15th, 2008 AT 1:32 PM

Please login or register to post a reply.

Sponsored links