CHEVY SERVICE 4WD LIGHT ON

2000 Chevrolet Silverado

Tiny

bforby

March, 9, 2008 AT 1:08 PM

Transmission problem
2000 Chevy Silverado V8 Four Wheel Drive Automatic 125000 miles

My service 4wd light is on and none of the lights on the push button are lit up. I changed the push button switch and that did not fix the problem any other ideas?

6 Answers

Tiny

rhall77

March, 11, 2008 AT 7:29 AM

You can try to disconnect the 4 wheel drive module for 30 seconds and see if it comes back on. Sounds like the module needs to be replaced. You may have to go to a dealer and have a scan tool put on it and see if the module is getting communication.

Tiny

bforby

March, 11, 2008 AT 8:04 AM

Is the module in the fusebox under the hood?

Tiny

rhall77

March, 11, 2008 AT 8:16 AM

Its behind the 4 wheel drive switch but above the drivers side fuse box. Its a 2 connector module.

Tiny

rhall77

March, 11, 2008 AT 8:38 AM

I hope this gets to soon, try to disconnect the fuse for 30 seconds instead of pulling the module out. This will do the same thing.

Tiny

bforby

March, 11, 2008 AT 1:39 PM

My father-in-law just had a friend of his hook it up to a scanner and it said the encoder motor is bad. He has one off a suburban of the same year do you think that one would fit?

Tiny

rhall77

March, 11, 2008 AT 1:56 PM

Im not 100% sure. You may wanna call a parts department and find out. What is the code that he got.

Please login or register to post a reply.

Pulling an Auto Trans? Easy Instructions
Code Read Retrieval/Clear