Won't start. Fuel injectors?

Tiny
DISTORTLIFE
  • MEMBER
  • CHEVROLET S-10
I have a 1998 Chevy S-10. It has a 4.3, its a 4x4, and a manual. Several months ago I began having problems every once in a while with it starting after it sat overnight. If I left it and came back later it would usually start. I soon learned that if I just kept cranking that eventually it would start. Now that doesn't even work.

The pump is on, I checked and have the proper fuel pressure, and I even jumped out the relay to make sure the pump stays on. It won't fire at all.

It will fire with starter fluid, so I must be getting spark, but it justs burns that up and dies.

Also, I don't show any codes. I did show a map sensor code after I had been messing with it, but I think that was because I was trying to start it with the starter fluid and I didn't have the air intake on.

I feel that none of the injectors are firing, but on a CSEFI system I believe this is difficult to check.

What would cause none of my injectors to work? PCM? Any other thoughts?

Thanks.
Do you
have the same problem?
Yes
No
Tuesday, October 30th, 2007 AT 7:41 PM

2 Replies

Tiny
BMRFIXIT
  • EXPERT
You should scan the system for code s
Use a gauge to check the fuel pressure and get an accurate reading
Check the TPS ( if its at WOT will shut off the injectors)
Check the fuses
Good luck
Was this
answer
helpful?
Yes
No
Tuesday, October 30th, 2007 AT 8:01 PM
Tiny
BLACKOP555
  • EXPERT
I would like you to check the fuel pressure reuglator. Also the pump could be bad it tells me that your not getting fuel to the engine.

Check the o rings around the injectors. They should also click when the engine is turned on or being started.
Was this
answer
helpful?
Yes
No
Tuesday, October 30th, 2007 AT 8:04 PM

Please login or register to post a reply.

Recommended Guides