Having problems with my Chevy Blazer starting

Tiny
LADYBUG_IOWA
  • MEMBER
  • CHEVROLET S-10
I have a 1993 S10 Blazer 4.3 l 4x4 with approximately 125,000 miles, And the truck will trun over but wil lnot start. We have replaced the relay, the fule pump and the fuel filter, and our mechanic has even replaced the gas tank, because it was all rotted out. Today he change the fuel injectors, thinking that was the reason why the vehicle is not starting however that still is not the problem, he says that there is plenty of fuel pressure behind it and that there is know no reason for it not to start. I will turn over but will not start. We have replaced the battery also. As you can tell this truck needs alot of work, we reinheriated back from someone in the family. Any suggestions on what we can have our mechanic check. We and him are at a loss as to what could be wrong with it, Oh yeah also if he sprays ether on the components it starts and runs until it burns off then it dies again and will not restart. And also he has noticed that heater core is shot on it too, Please any suggestions as to what to check and what to do would be great. Thanks
Do you
have the same problem?
Yes
No
Friday, July 20th, 2007 AT 4:22 PM

3 Replies

Tiny
CLY
  • MEMBER
"Oh yeah also if he sprays ether on the components it starts and runs until it burns off then it dies again and will not restart."

That statement tells me that the truck has spark, but does it have injector pulse? I would say that there is something going on with the fueling system. If it will run off of carb cleaner. Maybe a quad driver problem in the engine control module.

Just something to think about

Cly
Was this
answer
helpful?
Yes
No
Friday, July 20th, 2007 AT 9:11 PM
Tiny
LADYBUG_IOWA
  • MEMBER
It does have injector pulse and we change the ECM valve and still nothing. Thanks for the thought though.
Was this
answer
helpful?
Yes
No
Friday, July 20th, 2007 AT 9:21 PM
Tiny
CLY
  • MEMBER
Ok. The problem is with the fuel system. Does that have the one injector that goes threw what they refer to as a spider type deal with the injector nozzles on the end of them? I would make sure that no terminals are bent at that connection there has to be something to it right there, I am assuming that he is checking the injector pulse at that connection. If you are spaying stuff in the intake and it runs then the problem is that you are not getting fuel.I dont have a shcematic that I can look at here at home. I will look into it Monday and post more then. If you come up with anything else feel free to add it.

Cly
Was this
answer
helpful?
Yes
No
Friday, July 20th, 2007 AT 9:42 PM

Please login or register to post a reply.

Recommended Guides