1990 Chevy Lumina car won't start.

Tiny
SAMMIE.JAAY
  • 1990 CHEVROLET LUMINA

Engine Performance problem
1990 Chevy Lumina 6 cyl Two Wheel Drive Automatic 141000 miles

I have had this car for only a few months. I have had a full tune up and oil change. The problem at first was the car would shut off when driving if you took you foot off the gas. As long as your foot is on the gas your good. So they told me it was the map sensor? I changed that, then it started doing it again a couple weeks later. They said it was the idle sensor? Changed that. Everything was good for a while then one day it just died and wouldn't start. It sounded like it wanted to but just wouldn't. I was told it was the fuel pump, they changed it and now the car won't even turn over. But the battery is not dead and it seems that I am worse off then I started. SOME ONE HELP A GIRL OUT!

Do you
have the same problem?
Yes
No
Tuesday, June 24th, 2008 AT 5:03 PM

3 Replies

Tiny
RHALL77
  • MEMBER

Hi sammie,
Did you have the battery load tested. That maybe your problem. Have that done and get back to me.

Was this
answer
helpful?
Yes
No
Wednesday, June 25th, 2008 AT 11:29 AM
Tiny
TJEGZ
  • MEMBER

I think the battery too

Was this
answer
helpful?
Yes
No
Wednesday, June 25th, 2008 AT 11:36 AM
Tiny
SAMMIE.JAAY
  • MEMBER

I have a brand new battery that was put in. It still won't start. They are telling me that there was water in my gas tank? Sorry I am really clueless about all this. So the car won't start but sounds like it wants too. They are telling me to change the idol sensor that the water damaged it, but I just got that changed two months ago.?

Was this
answer
helpful?
Yes
No
Sunday, June 29th, 2008 AT 7:12 PM

Please login or register to post a reply.

Other Engine No Start Questions