MERCESES BENZ 4MATIC

Chevrolet Impala

Tiny

bknowler

January, 3, 2006 AT 9:17 AM

I have a 1992 MB 300TE with 4matic. The 4matic yellow light does not go out, so I assume the 4matic is not working. I have had the module tested, it is OK. The transfer case is OK, as is everything else we've checked. Any ideas or suggestions?

FOUND 830 RELATED QUESTIONS

Ecm Problem

88 ANSWERS

4 Answers

Tiny

2CarPros Ken

January, 4, 2006 AT 10:47 AM

You are going to need to scan it for trouble codes and go from there.[/Url]

Tiny

louzbenz904x4

December, 14, 2006 AT 7:17 PM

I HAVE AN OWNERS MANUAL AND IT INFORMS ME OF A TEST LEVER THAT DE ACTIVATES THE 4 MATIC I PULL IT THE LIGHT COMES ON, AND IT DISABLES THE TRANSFER CASE, ALSO SELF LEVELLING FUCTION, ALSO HAD A LIGHT COME ON AFTER REPLACIONG O V P RELAY ( OVER VOLTAGE )
HAD TO REMOVE 4 MATIC CPU when they put it back I guess the connection was not quite correct I removed and replacxe re/re 4 amtic cpu and light went off hope it helps if your still interested

Tiny

louzbenz904x4

December, 16, 2006 AT 10:59 AM

I have just replaecd all hydraulic oil and transfer case fluids, I realize that if there is any air in the system it may be trapped, mine stayed on and I bled the system at the test valve and now light is back out, and alll is good, hope any info helps

Tiny

2CarPros Ken

December, 18, 2006 AT 11:29 AM

Good info, thanks for the input, : D

Please login or register to post a reply.

How to gather codes Ford Explorer
Code Read Retrieval/Clear
Code Read Retrieval/Clear Chevrolet Camaro
Code Read Retrieval/Clear Honda Civic
Code Read Retrieval/Clear Mercedes Benz
Code Read Retrieval/Clear Mercedes-Benz C230
Code Read Retrieval/Clear - Dodge Stratus