Caravan problem

Tiny
GUY
  • CHEVROLET IMPALA

Hi there
I have a 93 caravan 230,000km and I just got a oil change and belts replaced. Ive put alot of money into this van in the last year or so with new sparks, wires, oil pump, exaust, fuel pump, filters, starter, battery, etc. Last night I was driving along the highway at 50mph and when I came to a uphill section the car started to stuggle and eventually all power to the wheels were lost and I had to pull over. The engine was still running but whenever I shifted into drive I would just slowly roll back with only a few sputters of momentem. After turning off the car for 10 mins or so the car would start up fine and id be on my way for another 40 mins untill it would all happen again.

Do you
have the same problem?
Yes
No
Monday, January 2nd, 2006 AT 8:04 PM

3 Replies

Tiny
GARCEAU83
  • MEMBER

Try changing your fuel filter if you haven't already done so. If that doesn't do it, we need to see what is causing it. Fuel or Spark.

Garceau83

Was this
answer
helpful?
Yes
No
Friday, January 6th, 2006 AT 4:26 PM
Tiny
HAYSEED
  • MEMBER

I have a 94 Voyager it had what sounds like the same problem. Turned out to be the torque converter. Are there any trouble codes? You can check by turning the ignition switch ON-OFF-ON-OFF-ON then count the flashing sequences of the service engine light. Each code is two digits, ie flsh, flsh, pause flsh, flsh, flsh, flsh = code 24. Codes may continue to flash in two code sequences so keep watching. Code 55 signals the end of the codes.

Hayseed

Was this
answer
helpful?
Yes
No
Friday, January 13th, 2006 AT 6:32 PM
Tiny
GARCEAU83
  • MEMBER

Found my problem. Bad injector and sricking valve.

Thanks

Was this
answer
helpful?
Yes
No
Friday, January 13th, 2006 AT 6:44 PM

Please login or register to post a reply.

Other Fuel System Pump Replace/Remove Questions