2007 Chevy Impala Battery Drain

Tiny
JOE@SPSIDEALSOLUTIONS.COM
  • MEMBER
  • 2007 CHEVROLET IMPALA
  • 6 CYL
  • FWD
  • AUTOMATIC
  • 60,000 MILES
I have replaced battery - and the new battery goes dead after overnight
Do you
have the same problem?
Yes
No
Thursday, December 31st, 2009 AT 6:53 PM

19 Replies

Tiny
KEN
  • ADMIN
Hey Joe,

You have something that is staying on over night, we have a great article that will help you troubleshoot the problem and get you back on the road.

https://www.2carpros.com/articles/car-battery-dead-overnight

Please run some tests and get back to us so we can continue helping you.

Best, Ken

Was this
answer
helpful?
Yes
No
-2
Wednesday, January 4th, 2017 AT 10:19 AM
Tiny
CHEVYBABY1976
  • MEMBER
  • 2002 CHEVROLET IMPALA
Engine Cooling problem
2002 Chevy Impala 6 cyl Front Wheel Drive Automatic

There is a switch on my Impala under the hood in the area where the battery is maybe a little above where the battery sits but I want to know should that switch be pushed in the up position or should it be in the down position? Does that have anything to do with why my battery wont stay charged properly?
Was this
answer
helpful?
Yes
No
+1
Wednesday, January 4th, 2017 AT 10:19 AM (Merged)
Tiny
JACOBANDNICKOLAS
  • EXPERT
I don't think the switch has anything to do with it. Have you had the alternator tested? The alt can charge, but if it has a bad diode, it can kill the battery overnight. Also, check this out to see if there is a draw on the battery:

http://www.2carpros.com/first_things/why_is_my_car_battery_dead_over_night.htm

Let me know what you find.
Was this
answer
helpful?
Yes
No
Wednesday, January 4th, 2017 AT 10:19 AM (Merged)
Tiny
HEAVVYREVVY
  • MEMBER
  • 2000 CHEVROLET IMPALA
  • 6 CYL
  • FWD
  • AUTOMATIC
  • 120,000 MILES
Electrical problem
2000 Chevy Impala 6 cyl Front Wheel Drive Automatic 120000 miles

my wife drove the car to a store, she was inside for 30 min or so - when she came out the battery was completely dead. When I arrived (about an hour or two later) I hooked the jumper cables and they started to smoke I unhooked them looked at a couple of fuses hooked them back - after about fifteen minutes of jumping the car started - but the battery was dead when I got home. What am I looking for?
Was this
answer
helpful?
Yes
No
Wednesday, January 4th, 2017 AT 10:19 AM (Merged)
Tiny
SERVICE WRITER
  • EXPERT
How old is the battery?

Check the water in the battery and make sure it's full unless this is a sealed battery in which case be sure the green light (eye) is on.

IF all good and your connections are clean and tight, trickle charge it overnight. Then check the voltage, should be 12.6v. Then check the draw on the battery and be sure it's 30 milliamps or less.

What we are trying to determine is that if the battery can take and hold a charge, deciing if there is a parasitic draw that is excessive or if it is not being charged.
Was this
answer
helpful?
Yes
No
Wednesday, January 4th, 2017 AT 10:19 AM (Merged)
Tiny
HEAVVYREVVY
  • MEMBER
The battery was dead - wouldn't take a charge. I think it was the original or at least a dealer replacement. I put a new battery in and had a parasitic draw of.046.
I pull each fuse on the driver's side individually until I pulled the one next to the gray box ( the bottom left hand side if you are looking straight on.) According to the eautorepair guide that you advertise it is marked CLSTR/BCM. When I pulled that one the draw dropped to.001.
Was this
answer
helpful?
Yes
No
Wednesday, January 4th, 2017 AT 10:19 AM (Merged)
Tiny
SERVICE WRITER
  • EXPERT
That circuit is going to have a high draw, if your left with such a little draw after pulling that one, it tells me there is no significant draw on another circuit. The bcm was probably not in it's sleep mode which could explain the moderately higher draw. 46 Ma really doesn't fit the quick loss of charge.

I would go the the alternater output next.
Was this
answer
helpful?
Yes
No
+1
Wednesday, January 4th, 2017 AT 10:19 AM (Merged)
Tiny
HEAVVYREVVY
  • MEMBER
I hooked the new battery up and drove it to the nearest auto parts store. The alt is putting out 32 -35 amps rather than the 102 amps expected. The guy testing it seemed to think that the abnormal drawdown might even be coming from this. And another wrinkle in this my radio now doesn't work.
Was this
answer
helpful?
Yes
No
Wednesday, January 4th, 2017 AT 10:19 AM (Merged)
Tiny
SERVICE WRITER
  • EXPERT
Okay. Makes sense alternater is way out of spec. Get a good one.I like napa premium, USA As Delco or Paladdium brands myself.

Does the RAdio say "lock".

Need a code from the dealer to unlock it. It's a protection thing so if the radio is stolen it is no usable.
Was this
answer
helpful?
Yes
No
Wednesday, January 4th, 2017 AT 10:19 AM (Merged)
Tiny
HEAVVYREVVY
  • MEMBER
Actually the radio doesn't do anything - no display at all. I didn't know how the lock thing worked. This is like there is no power.
I plan to go to Napa today for the alernator.
Was this
answer
helpful?
Yes
No
Wednesday, January 4th, 2017 AT 10:19 AM (Merged)
Tiny
SERVICE WRITER
  • EXPERT
After the alternater is in and the charging system is working, we can go after the radio. IF there is still no display afterwards, check the fuse to start with.
Was this
answer
helpful?
Yes
No
Wednesday, January 4th, 2017 AT 10:19 AM (Merged)
Tiny
HEAVVYREVVY
  • MEMBER
Took longer to get to this than I expected, but the new alt is in. I'm still getting a draw - now it is down to 0.40, so at least I'm making some headway - but that's still too high right?
Was this
answer
helpful?
Yes
No
Wednesday, January 4th, 2017 AT 10:19 AM (Merged)
Tiny
SERVICE WRITER
  • EXPERT
IT's on the high side, but it may not be out of the park either. IS the battery going dead anymore?

The bcm fuse took all but 1 milliamp. So either ther is a problem on the circuit or, it is acceptable. If the battery isn't going dead and it sets for a few days, I wouldn't worry about it. IF it isn't holding a charge then, yeah, a second problem needs to be nailed down. Time will tell.
Was this
answer
helpful?
Yes
No
Wednesday, January 4th, 2017 AT 10:20 AM (Merged)
Tiny
HEAVVYREVVY
  • MEMBER
I got it all together this morning so I guess I will let this sit overnight and see what happens.
Still no radio. Could having the battery disconnected cause this kind of radio problems?
Was this
answer
helpful?
Yes
No
Wednesday, January 4th, 2017 AT 10:20 AM (Merged)
Tiny
SERVICE WRITER
  • EXPERT
IT definitly will. Odd that there is no display. Fuse is good? Radio is in the on position? Like I mentioned, it should show loc when power is lost to the radio such as when the battery is disconnected.
Was this
answer
helpful?
Yes
No
Wednesday, January 4th, 2017 AT 10:20 AM (Merged)
Tiny
HEAVVYREVVY
  • MEMBER
Battery seems to be holding up without any problems - I didn't really check to see what kind of voltage was in the battery but it started without a hitch.
Thanks for your help on that!
Should I just go through the fuse box on the driver's side and see if that's my radio problem? Could it be the unusual draw on the battery? The cd player had already quit on it.
Was this
answer
helpful?
Yes
No
Wednesday, January 4th, 2017 AT 10:20 AM (Merged)
Tiny
SERVICE WRITER
  • EXPERT
Well since you had pulled the one fuse that only left the system with a one Ma draw, then we know the most this circuit can have is 1 Ma. So no, it can't be an excessive draw.

This is the fuse you are going after:


http://www.2carpros.com/forum/automotive_pictures/30961_imp1_1.jpg



If the fuse is good check for power getting to the radio connector and verify the ground is good.


http://www.2carpros.com/forum/automotive_pictures/30961_imp3_1.jpg



CD player: IF needbe.


http://www.2carpros.com/forum/automotive_pictures/30961_imp2_1.jpg

Was this
answer
helpful?
Yes
No
Wednesday, January 4th, 2017 AT 10:20 AM (Merged)
Tiny
HEAVVYREVVY
  • MEMBER
It was the fuse on the radio - so at least we're able to have some noise in the car again!
Thanks for your help!
Was this
answer
helpful?
Yes
No
Wednesday, January 4th, 2017 AT 10:20 AM (Merged)
Tiny
SERVICE WRITER
  • EXPERT
I like happy endings! It was my pleasure.
Was this
answer
helpful?
Yes
No
Wednesday, January 4th, 2017 AT 10:20 AM (Merged)

Please login or register to post a reply.

Recommended Guides