2002 Chevy Impala Engine idles roughly then stalls after he

Tiny
EMQUE
  • MEMBER
  • 2002 CHEVROLET IMPALA
  • 6 CYL
  • FWD
  • AUTOMATIC
  • 115,000 MILES
During in town use the car would refuse to start at random times. I'd go to pick up the car 20 minutes later and it would turn over just fine and run great. At these times when starting the engine would try to start, sputter then die. This weekend I nailed down exactly what is going on but not the solution. I drove on the highway for an hour and pulled into town, sat in the car while it was idling for fear of it not wanting to start again. After ten or so minutes the temperature gauge reached the mid stage (200 degrees I think) and the engine began to run rough and eventually sputtered and died. After that it would not start, it will turn over and sputter but die. I came back to the car 2 hours later and it ran fine (actually starting it up seemed as if it were "flooded") but the engine started a little rough at first, after that it ran great. The entire trip home on the highway it ran great also. The temperature gauge read apx. 160 degrees. I got into my driveway and let the engine idle and watched the temperature go up. Sure enough at 200 degrees it began idleing very rough then died. Rough start next morning but ran fine with a low engine temperature. Ive been told to replace the fuel pump by the mechanics that changed to fuel filter and said its a fuel line problem but after reading these forums Im thinking either MAF or O2 sensor. Thanks for the help!
Do you
have the same problem?
Yes
No
Monday, January 26th, 2009 AT 6:20 PM

1 Reply

Tiny
RHALL77
  • EXPERT
Is your check engine light on? Have it scanned and see what code is causing your concern. It could be the maf sensor. You can check it by disconnecting it and driving it to see if it takes care of your concern
Was this
answer
helpful?
Yes
No
Tuesday, January 27th, 2009 AT 6:30 PM

Please login or register to post a reply.

Sponsored links