After highway driving rough idle/misfire

Tiny
SOCRATES
  • MEMBER
  • 2003 CHEVROLET IMPALA
  • 122,000 MILES
Hi Car pro's,

Here a question from The Neterlands.(Here Impala's of 2000 and up are very rare. So nobody knows)

My 2003 Impala 3.4l has got me puzzled.
It starts and drives perfect BUT when you drive with it for a longer period of time (say about 30min and up) it starts to have misfires and rough idle but only when you come to a stop. You can feel it best when you go from 15mls and press the brake. Than you can feel the engine shake.
Changed sparkplugs, wires, changed leaky upper intake gasket, cleaned upper intake, trottle body and IAC, changed air filter, and PCV. (Switched out the coils. No change).
When I pulled out the IAC it was very dirty. When I cleaned it I pressed the valve. It was going firm but I could press it rather easy. The most strange thing is that if you drive within city limits the problem goes slowly away (it flattens out) and after about 10 min it is working perfect again.
Had pending code P0302. Checked compression. Rates are 1= 150psi, 2=143psi, 3=152psi, 4=149psi, 5=153psi, 6=150psi. Checked passages of EGR and they are clean. Hope that anyone has an idea.

Best regards from The Netherlands,
Bart
Do you
have the same problem?
Yes
No
Wednesday, October 19th, 2011 AT 6:38 PM

1 Reply

Tiny
HMAC300
  • EXPERT
Check your fuel pressure it should be 52-59 psi or 356-405 Kpa. It may be getting the pump hot when driving and dropping off. If not that you could have an injector problem. Youmight try some professional cleaners where it is introduced through the fuel rail. Thoses work the best.
Was this
answer
helpful?
Yes
No
Wednesday, October 26th, 2011 AT 12:30 AM

Please login or register to post a reply.

Sponsored links