2000 Chevy Impala

Tiny
20IMPALA00
  • MEMBER
  • 2000 CHEVROLET IMPALA
  • 6 CYL
  • FWD
  • AUTOMATIC
  • 128,000 MILES
My wife was driving home car sputtered for a second then shut off, vehicle starts but will not stay on, unless you give it some gas, if you manage to get it running it runs rough. My guess is the fuel filter. Vehicle has almost new battery, recent oil, also radiato flush, and trans flush with 10k miles. Any advice is greatly appriciated.
Do you
have the same problem?
Yes
No
Tuesday, October 28th, 2008 AT 7:52 PM

8 Replies

Tiny
MASTERTECHTIM
  • MEMBER
Not fuel filter, I would imagine its a faulty ignition coil or ignition system breakdown. You can try removing spark plug wires at the coil towers one at a time and see if one coil has no spark output. Hope this helps
Was this
answer
helpful?
Yes
No
Tuesday, October 28th, 2008 AT 7:57 PM
Tiny
20IMPALA00
  • MEMBER
I have replaced all 3 ignition coils, spak plugs and wires, and now the fuel filter. Car turns on but starts to run rough skanner code p0172 : system to rich(bank 1). Checked under the hood because car shut off on its own plug wire #1, #3, and #5 are hot to the touch, #3 more than the rest, and #2, #4, and #6 are normal. What can I do to correct this.
Was this
answer
helpful?
Yes
No
-1
Saturday, November 8th, 2008 AT 6:11 PM
Tiny
MASTERTECHTIM
  • MEMBER
Remove the fuel pressure regulator vacuum hose on the fuel rail I bet you have gas in it. Sounds like the diaphram has ruptured causing raw fuel to enter the vacuum line causing the rich condition.
Was this
answer
helpful?
Yes
No
Sunday, November 9th, 2008 AT 5:30 AM
Tiny
20IMPALA00
  • MEMBER
Decided to change fuel pressure regulator but still not resolved, check engine light came on, scanned, code is P0300 (random/ multiple cylinder misfire detected.
Was this
answer
helpful?
Yes
No
Thursday, November 13th, 2008 AT 7:49 PM
Tiny
MASTERTECHTIM
  • MEMBER
Im at a loss on this one. It seems like you covered all most common areas. Maybe install fuel pressure gauge and actually watch fuel pressure. Also check coolant temp sensor on the wscan tool and make sure its not reading too cold, for example if the temp sensor is reading -40 degrees then the computer will compensaate and make vehicle run rich.
Was this
answer
helpful?
Yes
No
Friday, November 14th, 2008 AT 2:30 PM
Tiny
20IMPALA00
  • MEMBER
Tried all possible options with no luck, finally took to repair shop had diagnostic test, result was bad mass air flow sensor. This was a learning experience for me hopefully for you as well. Thank you for your insight on this problem.
Was this
answer
helpful?
Yes
No
Thursday, November 20th, 2008 AT 10:45 AM
Tiny
CHEVY BOUND
  • MEMBER
Before I trade my car in - was your eventual fix expensive?
Was this
answer
helpful?
Yes
No
Sunday, December 7th, 2008 AT 6:55 PM
Tiny
MASTERTECHTIM
  • MEMBER
A mass air flow sensor is about 100 dollars
Was this
answer
helpful?
Yes
No
Monday, December 8th, 2008 AT 6:22 AM

Please login or register to post a reply.

Recommended Guides