Seems to Idle Rough when Starting

Tiny
ASHLEY52105
  • MEMBER
  • 2006 CHEVROLET EQUINOX
Engine Performance problem Front Wheel Drive Automatic 59000 miles

My equinox seems to idle rough when starting sometimes not at every start and will continue to idle rough like its not getting gas until you tap the gas pedal. Once you tap the gas pedal it idles normally. This issue had happened only once or twice and most of those times I noticed it was when my fuel level was low, but it does it now regardless if I have a full tank of gas or 1/2. I do have onstar diagnostics which have proven to be accurate in the past with most issues but wondering if it could be possible fuel filter causing issue which would not show up on diagnostics
Do you
have the same problem?
Yes
No
Sunday, May 3rd, 2009 AT 9:28 AM

3 Replies

Tiny
KEN
  • ADMIN
Hello,

Two things come to mind, first s a vacuum leak which you can find out by following this guide.

https://www.2carpros.com/articles/how-to-use-an-engine-vacuum-gauge

The next is old spark plugs, have you replaced them recently?

Here is a guide to help you get the problem fixed.

https://www.2carpros.com/articles/how-to-change-spark-plugs

and

https://www.2carpros.com/articles/engine-vibration-at-idle

Please let us know what happens.

Cheers, Ken

Was this
answer
helpful?
Yes
No
Wednesday, June 7th, 2017 AT 1:16 PM
Tiny
  • MEMBER
  • 2006 CHEVROLET EQUINOX
  • 10,150 MILES
I had a misfire in cyl 1 I changed all plugs and wires since car was hitting 100,000 miles. Well the #1 plug was stuck I took it to the dealership where I bought the car. Tbey ended up replacing the heads and re threading. The car worked great for about a week and a half. We drove about 800 miles to VA car was fine then on the trip home we had about 100 miles to go when car started misfiring wheb accelerating and in reverse also rough idle. Finally CEL came on and started to flash. We pulled over and turned the car off for about ten min. CEL stayed on bht no longer flashed we made it home and the next day we went to have it diagnosed and it now says misfire in cyl 6. What could be causing this? Also there is a strong fume odor coming from exshaust.
Was this
answer
helpful?
Yes
No
Wednesday, June 7th, 2017 AT 1:16 PM (Merged)
Tiny
HMAC300
  • EXPERT
Scan for codes and check fuelpressure, low fuel pressure will cause misfires
Was this
answer
helpful?
Yes
No
Wednesday, June 7th, 2017 AT 1:16 PM (Merged)

Please login or register to post a reply.

Recommended Guides