Brake lights not working?

Tiny
KICKFLIP666777
  • 2006 CHEVROLET COLORADO

Electrical problem 4 cyl Two Wheel Drive Automatic 40000 miles

The brake lights do not work, however, when I lock my car they flash so it's not a bulb issue. The cruise control doesn't work and the brake switch shares a fuse with it, but the fuse is not blown. Any answers?

Do you
have the same problem?
Yes
No
Wednesday, April 7th, 2010 AT 2:17 PM

16 Replies

Tiny
2CARPROS KEN
  • ADMIN
  • 11,672 POSTS

It sounds like you have a brake light switch that is not triggering the BCM. Here is a guide and some wiring diagrams (below) to help you confirm the failure.

Here is a guide to help you test trough the switch

https://www.2carpros.com/articles/how-to-use-a-voltmeter

Please let us know what happens.

Cheers, Ken

Was this
answer
helpful?
Yes
No
Friday, October 13th, 2017 AT 3:19 PM
Tiny
ANDREWARBAUGH
  • 2006 CHEVROLET COLORADO
  • 20,000 MILES

Left brake light and left front turn signal don't work as such, but the light bulbs work when used for parking lamp and rear turn signal. The left brake light doesn't turn on when the brake is pushed, but the top bulb works when the headlamps are on and the second bulb works for the turn signal. Right side brake light functions normally. The front left turn signal doesn't work but the bulb is on when in park. What can I do to fix this?

Was this
answer
helpful?
Yes
No
Friday, October 13th, 2017 AT 3:20 PM (Merged)
Tiny
FIXITMR
  • MEMBER

Have you checked effected bulbs? Are they dual element?

Was this
answer
helpful?
Yes
No
Friday, October 13th, 2017 AT 3:20 PM (Merged)
Tiny
RUSS0196
  • 2007 CHEVROLET COLORADO
  • 3.7L
  • 5 CYL
  • 4WD
  • AUTOMATIC
  • 123,000 MILES

Brake lights quit working on me. Bulbs look good and the brake switch tested good with volt meter. Im stumped and need help.

Was this
answer
helpful?
Yes
No
+2
Friday, October 13th, 2017 AT 3:20 PM (Merged)
Tiny
JDL
  • EXPERT
  • 16,345 POSTS

Do you have highmount brake lite on this vehicle, does it work? If neither works, have to check voltage to and from brake switch. Maybe you already did?

Was this
answer
helpful?
Yes
No
Friday, October 13th, 2017 AT 3:20 PM (Merged)
Tiny
JDL
  • EXPERT
  • 16,345 POSTS

Just wanted to add the diagram. The orange wire carries voltage to brake switch. When brake switch is activated, the lite blue wire carries voltage for brake lamps. Did you check brake fuse?

Was this
answer
helpful?
Yes
No
+2
Friday, October 13th, 2017 AT 3:20 PM (Merged)
Tiny
RUSS0196
  • MEMBER

Wow thanks for the fast reply. I have checked voltage from both orange and blue wires and everything checks out the circuit opens and closes.I even checked voltage at my trailer hook up in the back and it gets 12 bolt while pressing on the brake and 0 when depressed.

Was this
answer
helpful?
Yes
No
Friday, October 13th, 2017 AT 3:20 PM (Merged)
Tiny
RUSS0196
  • MEMBER

Oh also yes I have checked the fuse.

Was this
answer
helpful?
Yes
No
Friday, October 13th, 2017 AT 3:20 PM (Merged)
Tiny
RICKY749
  • 2005 CHEVROLET COLORADO

2005 Chevy Colorado

my colorado's brake lights dont work it has good
connection, good fuses, and good bulbs dont know problem.

Was this
answer
helpful?
Yes
No
Friday, October 13th, 2017 AT 3:20 PM (Merged)
Tiny
JACOBANDNICKOLAS
  • EXPERT
  • 68,377 POSTS

At the top of the brake pedal is the brake light switch. Make sure it is adjusted and is getting power both in and out.

Was this
answer
helpful?
Yes
No
Friday, October 13th, 2017 AT 3:20 PM (Merged)
Tiny
JDL
  • EXPERT
  • 16,345 POSTS

At the rear tail-lamp assembly, did you check for voltage at the light blue wire with brake switch activated? Anything there? Also, the black wire is ground, check that, also. Note some of your other rear lamps use the same ground as the brake lite.

Was this
answer
helpful?
Yes
No
Friday, October 13th, 2017 AT 3:20 PM (Merged)
Tiny
JDL
  • EXPERT
  • 16,345 POSTS

Sorry, that last diagram was wrong. I grabbed the wrong one.

Was this
answer
helpful?
Yes
No
Friday, October 13th, 2017 AT 3:20 PM (Merged)
Tiny
JDL
  • EXPERT
  • 16,345 POSTS

I'll try it, again.

Was this
answer
helpful?
Yes
No
Friday, October 13th, 2017 AT 3:20 PM (Merged)
Tiny
RUSS0196
  • MEMBER

Ok. I have just tested the blue wire at the tail light. I dont know if this means anything bit im getting.08 volts when peddle is pressed and zero when depressed. Thought! Could the voltage be getting drawn elswhere? I tested the connections under the truck where the wires split off to each light assembly and I get 12 volts at the connector to the T and 12 volts after.

Was this
answer
helpful?
Yes
No
Friday, October 13th, 2017 AT 3:20 PM (Merged)
Tiny
RUSS0196
  • MEMBER

Hello. So after some more thought I just decided to use my reverse bulb in the brake socket and wala it works. I inspected both bulbs well and they did not look bad, the filament was still intact but I guess they were both bad. I appreciate all the help you gave me and I will be using car pros from now on if I need it

Was this
answer
helpful?
Yes
No
Friday, October 13th, 2017 AT 3:20 PM (Merged)
Tiny
JDL
  • EXPERT
  • 16,345 POSTS

I'm glad you got it going your way.

Was this
answer
helpful?
Yes
No
Friday, October 13th, 2017 AT 3:20 PM (Merged)

Please login or register to post a reply.

Recommended Guides