1998 Chevy Camaro temp gauge/ oil gauge

  • 2 POSTS

Electrical problem
1998 Chevy Camaro 6 cyl Two Wheel Drive Automatic 120000 miles

I bought this car about 4 months ago and noticed that both gauges didnt work but I bought the car anyway cause I thought it would be something easy to fix. Well. I took it to a shop and they did not know what was wrong with it. What it does it when u turn the car on the oil gauge goes all the way over to the other side as if the pressure way really high and the temp gauge stay down as if it was hot at all. And this is under normal driving (on the highway or in town) but as soon as you stopat a light or anything with the car still running but the car not moving the temp and oil gauge go to where they should be when the car is running but when the car starts moving again the gauges go right back to the same spot they did before. I just dont know what to do and I dont like to drive the car cause I dont know if it is over heating or the oil pressure is to much or whatever it maybe and I was hoping maybe you might know what is causing this thank you for your time

Do you
have the same problem?
Monday, August 4th, 2008 AT 10:14 PM

1 Reply

  • 263 POSTS

First thing id say is change the temp switch but it works when stopped right?You need to take car to electrical auto shop not a mechanic. I would say that your gauge cluster is not working good. It seems to me. Try and change the cluster with another.U can get one at ebay used. My brother got one for his camaro for 35 bucks used with high miles but who cares as long as it works. Good luck

Was this
Wednesday, August 6th, 2008 AT 2:49 PM

Please login or register to post a reply.

Recommended Guides