2002 Chevy Blazer? On an 02 Blazer that stalls after put I

Tiny
BREAZY916
  • 2002 CHEVROLET BLAZER

Engine Mechanical problem
2002 Chevy Blazer 6 cyl Four Wheel Drive Automatic 79000 miles

Ok so I have a 2002 Chevy Blazer 4x4. We just got back from our camping trip, and it ran well. I went out to leave and it wouldn't start. No lights, no crank, nothing! We jumped it, and it started but it would not stay started w/o pressing the gas. So my thought was battery/alternator. We took the battery out and had it tested and it was fully charged (meaning the alternator and battery are fine). So when we put the battery back in it would turn over, but took a few times until it finally stayed started (sounded bad). We let it run for a few minutes and were going to test drive it. When we put the car in drive it immediately died. Started it up and tried again. Same result. I noticed some condensation out of the tailpipe and some under the car. I am not sure if that has anything to do with it, but it is not cold out here and the ac was not on. We drove the car for a while earier too. So any mechanincs out there have any idea what we should check next? Thank you for your imput!

Do you
have the same problem?
Yes
No
Sunday, May 25th, 2008 AT 6:33 PM

3 Replies

Tiny
OBXAUTOMEDIC
  • EXPERT
  • 3,770 POSTS

OK, you say you had Battery tested and it is fully Charged, what about the Cold Cranking Amps? If the CCA aren't up to snuff it could cause the no start. You also said that after putting battery back in it would turn over, so it may be a ground problem check all connections and make sure they are all clean and making good contact.

Now how do you know the Alternator is good? Did you have it tested. It may be charging just not enough. If you have a digital volt ohm meter you can check the out put. It should be charging at 13.6 to 14.2.

The stalling could be caused by the lack of voltage.

Post responses here

Was this
answer
helpful?
Yes
No
+1
Monday, May 26th, 2008 AT 8:06 PM
Tiny
BREAZY916
  • MEMBER

Well this moring we were planning on having it towed to my mechanic. When we went out to try starting it agian it started right up, and it did not stall this time when it was put into gear. We did end up driving it over there with no problems. He tested the alternator and said it seemed to be fine and doing what it was supposed to. So, after being driven around today it seems to be running just fine. I am thinking that taking the battery out and letting it rest over night did the trick. I am hopeful anyways =) Thank you for you response!

Was this
answer
helpful?
Yes
No
+1
Monday, May 26th, 2008 AT 10:57 PM
Tiny
DAMSEL IN DISTRESS 1
  • MEMBER

I also have 2002 Chevy blazer. Well I took it to shop n he said it was catylist converter, it would stall n buckle down when gear. Also eat up gas and overheat. So he changed converter and when leaving it sounded like a truck worse than when was messed up. He advised me that it would run like that cuz I needed new spark plugs, one was cracked, and cuz he bought a generic cytylist converter. I left not happy with sound n was smelling bad like exhaust.
I took it to a muffle place and I have 2 wholes in exhaust pipes. One right by motor n pieces of gasket was missing in "y"pipe. And explained that they suppose to replace both at one. Pieces of converter breaks off n blocks muffler. And that it doesn't matter car won't sound or smell or drive same even with expensive converter. So called original mechanic told him n I took it n showed him n said he contracted the job n help fix it. Well I didn't cuz how could he not check. He's reputation is on his work. Didn't trust him. Sooo car got worse n would go only 10 miles n sometimes due n not start for some time. So took to other mechanic n it was dead the battery so we boosted it n took off 1/2 a block n died.
We put gas just in case n boosted it. It would turn n catch but chocking.. So I'd pump gas while turning key. N it would catch n I'd let go of key n it die. We adjusted cables n tried repeatedly to boost no luck. And when took off cables it wouldn't do anything at all no lights no nothing. Only when connected to cables. So new mechanic changed spark plugs n put new muffler n welded y pipe closed. Said he went to start n wouldnt. That it need a new starter. Wouldn't catch or turn. So he put new starter on n it started when put it gear it dyes. He don't know what's wrong. Please help

Was this
answer
helpful?
Yes
No
Thursday, December 8th, 2016 AT 3:44 PM

Please login or register to post a reply.

Other Engine Stall Questions