2001 Chevy Blazer excessive cranking - engine does not star

Tiny
CAB960
  • MEMBER
  • 2001 CHEVROLET BLAZER
  • 6 CYL
  • 4WD
  • AUTOMATIC
  • 140,000 MILES
My car lost all power the other day so I replaced the battery and all was fine for a couple of weeks and then one day the engine would not start and sounded like it did not have fuel. The next day I checked and it started immediately so I took it to a mechanic and he checked the pressure and was ok (45 - 50 psi). He said it may be the fuel pump and suggested I carry a small container with fuel and if it happened again I should pour a small amount of fuel in the intake and if it worked it would indicate the fuel pump. I've been driving for a whole week without incident and today it happened again after driving about 15 miles. I tried putting some fuel in the intake and for a very short moment it started the engine but quickly dropped off as soon as I released the accelerator. What other things should I look for?
Do you
have the same problem?
Yes
No
Wednesday, July 1st, 2009 AT 9:58 PM

1 Reply

Tiny
JACK42
  • MEMBER
Nothing, it sounds like it was the fuel pump. It will only run for a moment if you put a small amount of fuel in the intake. There is aschrader valve on the driver side of the distributor on thefuel line. Just remove htecap and push itin to see if any pressure is behind it, if not replace the fuel pump and fuel pump relay.I strongly advise using an A/C Delco pump, the rest are cheaper for a reason
Was this
answer
helpful?
Yes
No
Thursday, July 2nd, 2009 AT 7:52 AM

Please login or register to post a reply.

Recommended Guides