1996 Chevy Blazer stalls after 4 hours cools 10 minutes sta

Tiny
MLINDLEY
  • MEMBER
  • 1996 CHEVROLET BLAZER
  • V8
  • 4WD
  • AUTOMATIC
  • 143,000 MILES
My S10 blazer will stall after about 4 hours running. It will then stall and after about 10 minutes of cooling off it will restart and this will keep happening. Everyone is stumped. I had the fuel pump, filter, wire to the fuel pump, module, computer, crank sensor, and many tests done and everyone is stumped even the Chevrolet garage is stumped. There are no codes showing up when it has been tested. Any help would be greatly appreciated as everyone here is stumped. The garage had my vehicle for a month and tried everything. Thanks.
Do you
have the same problem?
Yes
No
Tuesday, October 21st, 2008 AT 12:13 PM

6 Replies

Tiny
RHALL77
  • MEMBER
You said it has to sit when it stalls for ten minutes to restart it. What are you loosing when it doesnt restart spark, fuel pressure, injector pulse.
Was this
answer
helpful?
Yes
No
Tuesday, October 21st, 2008 AT 4:14 PM
Tiny
MLINDLEY
  • MEMBER
I have had it stall while I was driving 3 different times and the last time was in an intersection. So when they test it now they let it sit and it will stall after 4 hours of running. It will restart after about 10 minutes from the stalling. Fuel pump and filter changed in June 2008, then all my problems started. They then changed the pick up coil, crank sensor and vapor tested and changed the computer. Those are not the problem. Everyone is stumped even the GM dealer here. Engine is good and transmission is good and the body is good. Would like to know what to try next. Getting expensive to fix. Any help is appreciated.
Was this
answer
helpful?
Yes
No
Thursday, October 23rd, 2008 AT 8:01 PM
Tiny
RHALL77
  • MEMBER
I under stand that but during the 10 minutes it doesnt start whats is missing. Injector pulse, fuel pressure or spark. These are the 3 main things that start a vehicle.
Was this
answer
helpful?
Yes
No
Friday, October 24th, 2008 AT 8:47 AM
Tiny
MLINDLEY
  • MEMBER
Well trying to restart it they tested the fuel pressure and it is fine. I just had a tune up and they said something about it has spark. As for the injector they said it isn't that. I had to go to the garage and ask. When it died the last time and the person who pushed me out of the intersection said it sounded like my fuel pump or battery. Both tested fine. Everyone is stumped. Ugh! I really like this vehicle but at my wits end.
Was this
answer
helpful?
Yes
No
Friday, October 24th, 2008 AT 11:44 AM
Tiny
RHALL77
  • MEMBER
It would really help if you knew what they said about the spark like if it was there. It sounds like it could be a ingnition module or a pick up coil.
Was this
answer
helpful?
Yes
No
Friday, October 24th, 2008 AT 2:41 PM
Tiny
MLINDLEY
  • MEMBER
The spark is there. The pick up coil was tested and replaced. Not sure about the ignition module will have to ask. I also had a complete tune up at the same time as they have been testing everything and trying. Anything Else I should ask while I am asking about the Ignition module? Thanks for all your help I am very appreciative with any information or things to try.
Was this
answer
helpful?
Yes
No
Friday, October 24th, 2008 AT 2:52 PM

Please login or register to post a reply.

Recommended Guides