1995 Chevy Blazer will not start

Tiny
MDESTROYER
  • MEMBER
  • 1995 CHEVROLET BLAZER
  • 6 CYL
  • 4WD
  • AUTOMATIC
  • 162,000 MILES
I bought this truck a month ago. It had an problem with starting sometimes it ended up being presure reg./Diaphram leaking. Replaced the injector unit problem solved for a few weeks. I have spark, fuel presure at the valve kind of lost now. What do you think I should try next?
Do you
have the same problem?
Yes
No
Tuesday, January 19th, 2010 AT 8:31 PM

7 Replies

Tiny
BMRFIXIT
  • EXPERT
What do you have for fuel pressure?
Was this
answer
helpful?
Yes
No
Tuesday, January 19th, 2010 AT 8:39 PM
Tiny
MDESTROYER
  • MEMBER
I have 55 to 60
Was this
answer
helpful?
Yes
No
Tuesday, January 19th, 2010 AT 9:09 PM
Tiny
BMRFIXIT
  • EXPERT
Anything below 55PSI and fuel pump need to be replaced
do you have good and strong spark at the coil and at the spark plugs !
Check for codes
check for injector pulse
check fuses
spray starting fluid in the throttle does it start
Was this
answer
helpful?
Yes
No
Wednesday, January 20th, 2010 AT 5:12 AM
Tiny
MDESTROYER
  • MEMBER
I do have good spark from coil and plugs. All fuses look ok too. I will try spraying sarter fluid into the intake see if it fires up. I just wanted to add everything was running fine after I replaced the injector the first time. Then what happened next was I was replacing the front driver side shock and when I was done try to start it and it would not start. I know there are some wires near that top bolt but I pretty sure I had them out of the way. DO those wires have any affect to the starting procedure?
Was this
answer
helpful?
Yes
No
Wednesday, January 20th, 2010 AT 5:57 PM
Tiny
BMRFIXIT
  • EXPERT
I dont think of any wires in that area to stop it from starting (I will look it up )
did the spray get it started?
Was this
answer
helpful?
Yes
No
Wednesday, January 20th, 2010 AT 7:57 PM
Tiny
MDESTROYER
  • MEMBER
Ok, here we go. Friend came over today with scanner too check for codes. He jokingly said watch it start for me on the first try. Well guess what it did. LOL! He checked the codes one said tps sensor and the other one said high voltage at coil. He cleared the codes and said try just driving it close to home and see if it happens again. Nothing we can do now if everything checking out ok for now.
Was this
answer
helpful?
Yes
No
Thursday, January 21st, 2010 AT 10:21 PM
Tiny
BMRFIXIT
  • EXPERT
TPS with wrong voltage will cause a no start as it will shut down the injectors
happy driving, thank you
Was this
answer
helpful?
Yes
No
Friday, January 22nd, 2010 AT 6:17 AM

Please login or register to post a reply.

Recommended Guides