1993 Chevy Blazer engine wont start

Tiny
JAMES1967
  • 1993 CHEVROLET BLAZER

Engine Mechanical problem
1993 Chevy Blazer 6 cyl Two Wheel Drive Automatic 145840 miles w vin code

ok engine wasnt getting spark changed plugs wires cap rotor and coil ra but ran ruff then it died pick up coil was bad changed distributor started agai but ran ruff put new fuel filter on now it wont run will start after sittying for awhile but wont idle then will die and wont start again I thin k its the fuel reg were the hell is it I cant find were it is in my chilton just what it is. I am assuming it is getting to much fuel becouse when it starts you can keep it runninng with the peddal. Am I correct or not

Do you
have the same problem?
Yes
No
Tuesday, February 23rd, 2010 AT 8:39 AM

25 Replies

Tiny
RACEFAN966
  • EXPERT
  • 5,127 POSTS

Ok first off I would need to know what the fuel pressure is before I can know if you are on the right track or not. Is there a way for you to check fuel pressure to see what it is. Also what is the 8th digit of the vin W or Z?

Was this
answer
helpful?
Yes
No
Tuesday, February 23rd, 2010 AT 9:35 AM
Tiny
JAMES1967
  • MEMBER

Ill have to buy a pressure ga vin code is w

Was this
answer
helpful?
Yes
No
Tuesday, February 23rd, 2010 AT 9:46 AM
Tiny
RACEFAN966
  • EXPERT
  • 5,127 POSTS

I do need to know what the fuel pressure is. This type of injection requires 62 psi to start and runs on 55 psi. The regulator for the injection is on the injector system which is inside the plastic upper plenum, see pic below.


http://www.2carpros.com/forum/automotive_pictures/249564_263451_1.jpg

Was this
answer
helpful?
Yes
No
Tuesday, February 23rd, 2010 AT 9:54 AM
Tiny
JAMES1967
  • MEMBER

Tested fuel presure 62 while cranking wont start at the moment I think its flooded again also what I have found is that the reg. Is under the intake man atached to the multi-port fuel injection assembly if this is corect will I have to replace the intire assembly

Was this
answer
helpful?
Yes
No
Tuesday, February 23rd, 2010 AT 10:24 AM
Tiny
JAMES1967
  • MEMBER

Also I suscribed to mitchell1 online can you tell me were to find this info there so I can get an exploded view

Was this
answer
helpful?
Yes
No
Tuesday, February 23rd, 2010 AT 10:32 AM
Tiny
JAMES1967
  • MEMBER

I changed the fuel reg I had a hell of a time getting it started but now I can start it but it wont idle and after I changed the reg the fuel pressure would run at 56 when eng is running but when the eng. Would die or I turnd eng off the presure woud drop to 0 but when I turn key on the presure would go to 64 is any of this normal and could the egr keep it from idling?

Was this
answer
helpful?
Yes
No
Tuesday, February 23rd, 2010 AT 6:26 PM
Tiny
RACEFAN966
  • EXPERT
  • 5,127 POSTS

Ok so have you pulled any of the spark plugs and looked them over. It may be that you have some bad spark plugs so check this first. If this looks good then if you would unplug the mass air flow unit and try to start it, does it idle now? It won't have much for throttle response but it should idle. Get back to me with what you find.

Was this
answer
helpful?
Yes
No
Wednesday, February 24th, 2010 AT 9:59 AM
Tiny
JAMES1967
  • MEMBER

I have changed all that I can think of now it will idle but at a high speed cant but it in gear it will die could I have gotten a bad cap and rotor

Was this
answer
helpful?
Yes
No
Wednesday, February 24th, 2010 AT 6:18 PM
Tiny
RACEFAN966
  • EXPERT
  • 5,127 POSTS

Ok that is great but have you pulled a couple sence to see if any happened to have gotten gas fouled? To answer you question on the cap and rotor yes you can get a bad one but not very common. Let me know what you find.

Was this
answer
helpful?
Yes
No
Thursday, February 25th, 2010 AT 9:04 AM
Tiny
JAMES1967
  • MEMBER

Yes I have pulled the plugs they look good gap is good I even cleaned the egr when I did get it started useing gas through the plentom it idled but at a high rate and when I pulled the mas air it died

Was this
answer
helpful?
Yes
No
Thursday, February 25th, 2010 AT 1:02 PM
Tiny
JAMES1967
  • MEMBER

I have changed the spark plugs all it will do is crank. I can start it by putting gas in the pletum intake. It will fire off and idle, but at 800 to 1000 rpm. It idles very smoth, but I cant put a load on it it will die. So I cant drive it I can rev it up fine, and it returns to the same idle. It will idle like this as long as I dont touch anything. If I pull the mas air sensor plug it will die. If I move the distiputor it dies. I have looked for vacume leaks but cant find any. I removed the plentum and ran the fuel pump and found no leaks. I have replaced the throttle pisition sensor, and cleand the egr, the plunger moves freely. I also cleand and mesured the iac, as far as I can tell its fine. This all started with the blazer dieing while I was driving and would not restart. The only thing I havent changed is the spider assembly or mpi what ever you wan to call it. But its getting fuel or it wouldnt run at all I assume.

Was this
answer
helpful?
Yes
No
Thursday, February 25th, 2010 AT 5:50 PM
Tiny
RACEFAN966
  • EXPERT
  • 5,127 POSTS

You said in a previouse response that the fuel pressure drops to 0 when you turn the key off. How quickly does it drop to 0? If you turn the key on and then off and on about 3 times will it start then? If not I am thinking we need to look at the fuel pump.

Was this
answer
helpful?
Yes
No
Friday, February 26th, 2010 AT 10:17 AM
Tiny
JAMES1967
  • MEMBER

I put in a new fuel pump

Was this
answer
helpful?
Yes
No
Friday, February 26th, 2010 AT 10:26 AM
Tiny
RACEFAN966
  • EXPERT
  • 5,127 POSTS

Don't matter I need to know what it is doing, the pump you put in may be no good. Please tell me what is it doing as I asked in the previouse response.

Was this
answer
helpful?
Yes
No
Friday, February 26th, 2010 AT 10:30 AM
Tiny
JAMES1967
  • MEMBER

Was this
answer
helpful?
Yes
No
Friday, February 26th, 2010 AT 10:33 AM
Tiny
RACEFAN966
  • EXPERT
  • 5,127 POSTS

Ok what does it drop to in 5 min time? You do still have good spark right? Have you checked the timing and have you checked for any vacuum leaks? If you unplug the mass air flow unit does it idle better?

Was this
answer
helpful?
Yes
No
Saturday, February 27th, 2010 AT 8:45 AM
Tiny
JAMES1967
  • MEMBER

I'm in the process of doinng that. If the iac is stuck open would that cause that and I took off the plentom and pulled the injectors ran the pump nothing is that normal for these or do they work on vacuum. And if I disconect the mas air it dies. The prssure drops slowly to 0 just acouple minutes

Was this
answer
helpful?
Yes
No
Saturday, February 27th, 2010 AT 10:17 AM
Tiny
JAMES1967
  • MEMBER

Well it was the idle position sensor was the incorect one it was holding the throttle open. And the injectors wernt right dont know what it was for sure but when through them ad now it starts but I cant put it in gear it will die i'm gettinng closer put still not right. Is there any way it could have jump a tooth on the timing chain and still run. And I have a good pump it was the fuel reg the small washer was allowing fuel to pass through now it holds it 58 for ever hasnt fallen yet

Was this
answer
helpful?
Yes
No
Sunday, February 28th, 2010 AT 5:43 PM
Tiny
RACEFAN966
  • EXPERT
  • 5,127 POSTS

OK getting closer. Didn't think it would the wrong TPS good catch. Now as for stalling in gear I think that is what you are telling me. How does it die, does it chug and stall or does it try to move the truck forward and die (kind of like it was a standard trans and you drop the clutch without touching the gas)? To answer your question with the chain it can but not real likely. If you feel the need to check get the engine on TDC with cylinder on up and the timing mark at 0 and pull the cap see where the rotor points.

Was this
answer
helpful?
Yes
No
Monday, March 1st, 2010 AT 9:00 AM
Tiny
JAMES1967
  • MEMBER

It kills it right away I put on the brake put it in gear it dies I dont know if you would call it a chug but if I give it a little gas it will go in gear. I do have it on stands. But for now i'm stuck till tomarrow its rainnig. The tps was holding the throttle open just eough to rase the idle there was a slight difference between years they typed in the wrong year

Was this
answer
helpful?
Yes
No
Monday, March 1st, 2010 AT 10:10 AM

Please login or register to post a reply.

Recommended Guides