1996 Chevy Astro starts and runs but missfires when acceler

Tiny
MATT67665
  • MEMBER
  • 1996 CHEVROLET ASTRO
Engine Mechanical problem
1996 Chevy Astro 6 cyl Two Wheel Drive Automatic

Hi I have a little confusing problem with my van. I have put new plugs and wires in it and it seems to not fix the problem. When I start it and drive it seems to run fine however when I accelerate it cuts out and when I get to 65mph it seems that its constantly miss fireing. It runs fine at 55 though. The service engine soon light says that its cylinder missfire. It don't matter what the fuel tanks at it still does it. When I load it down it seems to do this as well. What is the most common thing that they have a problem with?
Do you
have the same problem?
Yes
No
Monday, December 28th, 2009 AT 10:43 PM

4 Replies

Tiny
RASMATAZ
  • MEMBER
Check and test the following below:

Oxygen sensor
Dirty fuel injectors (cleaning the injectors often fixes this).
Bad MAP (manifold absolute pressure) sensor
Bad TPS (throttle position) sensor
Bad or dirty MAF (mass airflow) sensor
Low fuel pressure (leaky fuel pressure regulator or weak fuel pump)
Vacuum leaks (intake manifold, vacuum hoses, throttle body, EGR valve)
Bad gasoline (fuel contaminated with water or too much alcohol)

Sometimes, what feels like a hesitation is actually ignition misfire rather than lean misfire. The causes of ignition misfire may include:

Dirty or worn spark plugs
Bad plug wires
Weak ignition coil
Wet plug wires
Was this
answer
helpful?
Yes
No
Monday, December 28th, 2009 AT 10:51 PM
Tiny
OBXAUTOMEDIC
  • EXPERT
Ras you beat me to it.

But noticed that the Cap and Rotor weren't mentioned as to being changed.

.
Was this
answer
helpful?
Yes
No
Monday, December 28th, 2009 AT 10:56 PM
Tiny
MATT67665
  • MEMBER
Ok I did replace the coil as to there was white residue on the coil and I seen it arking in the dark. All the codes say is that its cylinder missfire nothing else it misses some times at 10 but mainly at 65 and faster and it smells of fuel and drinks it when its doing this as well
Was this
answer
helpful?
Yes
No
Monday, December 28th, 2009 AT 11:24 PM
Tiny
ROKJOK
  • MEMBER
I'm interested to see how this plays out.I just posted that my Suburban does the EXACT same thing. Your van probably does it too sometimes when accelerating into traffic or in town on occassion?
Was this
answer
helpful?
Yes
No
Tuesday, December 29th, 2009 AT 9:28 PM

Please login or register to post a reply.

Recommended Guides