1999 Chevy Astro miss fires

Tiny
KINGSMAN47
  • MEMBER
  • 1999 CHEVROLET ASTRO
  • 6 CYL
  • 2WD
  • AUTOMATIC
  • 152,000 MILES
When you first start it up it miss fires or just misses after the motor is hot it run good. I had bad gas in it now it's good gas with a v-checker reader on it it just saids miss fire
Do you
have the same problem?
Yes
No
Monday, October 26th, 2009 AT 10:07 AM

5 Replies

Tiny
OBXAUTOMEDIC
  • EXPERT
Hello,

Do you have the actual code it should be something like P0300 or P0301 - 306. If not your local parts store can pull the codes. Post them here.

Also when was your last tune-up?

.
Was this
answer
helpful?
Yes
No
Monday, October 26th, 2009 AT 10:30 AM
Tiny
KINGSMAN47
  • MEMBER
I get bought it it's a nice van so I don't know when it was last tuned-up. The code was P0300
Was this
answer
helpful?
Yes
No
Monday, October 26th, 2009 AT 1:51 PM
Tiny
OBXAUTOMEDIC
  • EXPERT
OK,

Here is the code def....

P0300 Random/Multiple Cylinder Misfire Detected

So, first thing I would do is pull a plug or 2 and see what they look like. If they look worn then I would do a tune-up and see if that corrects the problem. 8 out of 10 time is does.

If not other possibilities are....

Vacuum Leaks

Low Cylinder Compression

Weak Fuel Pump and/or Pressure Regulator

For more check out the link below...

https://www.2carpros.com/first_things/why_does_my_engine_run_rough.htm

.
Was this
answer
helpful?
Yes
No
Tuesday, October 27th, 2009 AT 10:06 AM
Tiny
KINGSMAN47
  • MEMBER
Thanks for your help I had a vacuum hose that was broken in two
Was this
answer
helpful?
Yes
No
Tuesday, October 27th, 2009 AT 1:57 PM
Tiny
OBXAUTOMEDIC
  • EXPERT
Ok, great did that fix the Misfire? If so congrats on the fix.

If not let me know so we can do more diagnosis.

.
Was this
answer
helpful?
Yes
No
Thursday, October 29th, 2009 AT 9:35 PM

Please login or register to post a reply.

Sponsored links