CEL CODE P2097, P2177 and P2187

Tiny
MULLET69
  • MEMBER
  • 2006 MAZDA 6
  • 87,000 MILES
Hi,

I'm having a problem right now with my Mazda 6i 2.3 2006. Three CEL code went on this week P2097, P2177 and P2187.

It all started when I changed my air filter. I took it for a ride after and the check engine went on. So I checked if any wires were disconnect but everyhting looks fine. Than I have clean my throttle body and MAF and also changed my spark plugs. Everything seems fine after that but I was just driving to work (0.5 km) at a speed of 50 km/h. I've soon as I went up to 80 km/h, the check engine pops up. It doesnt look like the car has a vaccum leak somewhere. Maybe the front oxygen sensor is the problem?

Please help me!

Thanks!

Do you
have the same problem?
Yes
No
Friday, June 14th, 2013 AT 11:12 AM

2 Replies

Tiny
HMAC300
  • EXPERT
This could be several things. Besides the maf check fuel pressure then check to see if evap vapor canister solenoid is stuck open or partially open it could also be an O2 sensor among other things, it's best a pro diagnose this so yu dont' end up changing a myriad of parts and still not fix the problem One thing you can check though is to see if your duct work is on correctly and has no holes in it.
Was this
answer
helpful?
Yes
No
Friday, June 14th, 2013 AT 12:26 PM
Tiny
KHLOW2008
  • EXPERT
The chart shows possible causes for the codes concerned and since the problem started after replacement of the air filter, I would start rechecking all those aroubnd the area first.
Was this
answer
helpful?
Yes
No
+1
Friday, June 14th, 2013 AT 12:29 PM

Please login or register to post a reply.

Sponsored links