Check engine light and rough idle

Tiny
ROBERT07
  • MEMBER
  • 2005 MAZDA 6
  • 3.4L
  • 4 CYL
  • 2WD
  • MANUAL
  • 170 MILES
Bought the car and has me scratching my head. It s tuning rough at idle and will stall out time to time. I have checked as well as I could visually and spraying carb cleaner to try to locate. No luck. It is showing p0300 and p0134 codes. The 02 sensor is a newer one but I haven't replaced it
If I unplug the IAC on the throttle body the car idles fine with out surging or stalling but in my opinion just a tad higher than normal but a lot better. I know the PCV s are common but I sprayed it well no change in rpms. I'm at a loss for words but I would say it would be a vacuum leak because it sounds like a Leak right around the throttle body area but I don't know if this noise I'm hearing is usual on a mazda 6 or not but I'm hoping there bid someway to tell me for certain for certain if it's a part or leak. Any guidance will be appreciated.
Do you
have the same problem?
Yes
No
Thursday, October 29th, 2015 AT 7:13 PM

3 Replies

Tiny
HMAC300
  • EXPERT
See pic for causes, check fuel pressure with a gauge and for the 300 code is amisfire so it may be from low fuel pressure or basic engine or any sensor. You may have an exhaust leak as well ad make sure all duct work has noholes in it prior to engine. 300 codes are a bitch to find so normally I tell people to go to apro so he can check everything, check compression as well. 55-65 psi for fp. We only list a 3.0L for this car so these are the specs i'm using.
Was this
answer
helpful?
Yes
No
Friday, October 30th, 2015 AT 7:03 AM
Tiny
ROBERT07
  • MEMBER
I'm sorry I did provide the wrong spec sorry. 05 mazda 6 3.2. I belive I found the issue. I am convinced it is a vaccum leak. I found it at the throttle body. So I replaced the gasket and in doing so I found a new seal in it already. So I am lost as to what to do but replace it. Just seems like it's not sealing doesn't look warped but that doesn't mean it isnt. I replaced the seal and sprayed again and it is still leaking. The car is running a little better so I think I probably sealed it a little better since the car isn't stalling now but it will surging and hesitates. Also down shifting causes engine to have a shake feeling to it most prevalent downshifting getting worse with each lower gear, as well as taking off. Also side notes I noticed, I change oil and plugs and wires. The plugs seemed tighten than usual like the engine has more than usual pressure and in doing research on this vehicle they are known for pcv valve issue wondering if could be clogged.I put premium gas in and light went off for a good bit but back on and never flashing. Any advise is much abliged. Thanks for all your time.
Was this
answer
helpful?
Yes
No
Sunday, November 1st, 2015 AT 3:13 PM
Tiny
HMAC300
  • EXPERT
Youpic didn't come through, check for cracks around it on intake and throttle body. If it isjust a gasket you might try using 2 or 3 and see if that cures it. If it's an Oring you can't so you'll have to see why it's leaking there.
Was this
answer
helpful?
Yes
No
+1
Sunday, November 1st, 2015 AT 3:52 PM

Please login or register to post a reply.

Recommended Guides