Car shuts off and then drives normally

Tiny
KRYPTECLIPSE
  • MEMBER
  • 1999 MITSUBISHI ECLIPSE
  • 2.0L
  • 4 CYL
  • AUTOMATIC
  • 80,000 MILES
This is probably the weirdest thing that has happened to my car. Sometimes when I turn on the car it just shuts off. Other times it shuts off when I come to a stop. I have noticed that when it doesn't shut off is when I keep it accelerated. The check engine light comes on and feels like its going to die. I have recently changed the ECU. I noticed it has been acting up like that afterwards. It does drive a whole lot better than before though. These are also some of the recent changes I have done.

Oil change and filter
egr
O2 sensors
PVC
PVC valve hoses
vacuum hoses
spark plugs and wires
fuel filter
fuel pressure regulator
put a fuel injector cleaner in the tank
fuel pump
air filter
coolant temperature sensor
idle control valve
intake air temperature sensor (IAT)
intake manifold gaskets
seafoam
brake booster hose

Thanks in advance
Do you
have the same problem?
Yes
No
Tuesday, June 23rd, 2015 AT 2:21 PM

3 Replies

Tiny
MHPAUTOS
  • EXPERT
Can you get a scan done and post the codes that are logged inn the ECU, that will be a good place to start.
Was this
answer
helpful?
Yes
No
Wednesday, June 24th, 2015 AT 2:03 AM
Tiny
KRYPTECLIPSE
  • MEMBER
There are no codes. Everything comes out as clean
Was this
answer
helpful?
Yes
No
Wednesday, June 24th, 2015 AT 7:05 AM
Tiny
MHPAUTOS
  • EXPERT
I am thinking that it may be an ignition module, I have seen these (but not on your model) fail intermittently when they get warm and start working when they cool down, when it next fails check for spark and injector pulse.
Was this
answer
helpful?
Yes
No
Wednesday, June 24th, 2015 AT 2:29 PM

Please login or register to post a reply.

Recommended Guides