Car has a rough idle, slow acceleration

Tiny
FEZHALL17
  • MEMBER
  • 2006 KIA SORENTO
  • 3.5L
  • V6
  • 2WD
  • AUTOMATIC
  • 87,000 MILES
No power, running rough. I have changed spark plugs, o2 sensors, and ignition coils, nothing has changed.
Do you
have the same problem?
Yes
No
Saturday, June 25th, 2022 AT 5:12 AM

1 Reply

Tiny
JACOBANDNICKOLAS
  • EXPERT
Hi,

Oftentimes, power loss and poor running conditions are caused by a plugged catalytic converter. By chance, is there any rattling from the exhaust, odd smells, or a hissing sound?

Take a look through this link and let me know if it mirrors what you are experiencing:

https://www.2carpros.com/articles/bad-catalytic-converter-symptoms

Also, is the check engine light staying on when the engine is running? If it is, have you scanned the computer for diagnostic trouble codes? If not, I recommend doing this. Here is a link that explains how to scan the can-bus system:

https://www.2carpros.com/articles/can-scan-controller-area-network-easy

If you feel it does seem to mirror what you experience, remove the upstream oxygen sensor. That is the one before the catalytic converter. With it out, see if there is any change in how it runs. The small opening is an escape for exhaust gases if the converter is plugged in.

If you don't have a scan tool, often times a parts store will check for codes free of charge. f you do have a live data scanner, let me know what the short-term fuel trims are at operating temperature.

Let me know.

Joe
Was this
answer
helpful?
Yes
No
Saturday, June 25th, 2022 AT 10:08 PM

Please login or register to post a reply.

Sponsored links