Car backfired and lost some power

Tiny
MTMCALL
  • MEMBER
  • 1998 TOYOTA AVALON
  • 214,000 MILES
Cleaned EGR TUBE, replaced EGR valve. Ran great until 3 days ago. Noticed a decrees I fuel mileage on Monday and Tuesday had the car backfire and lose power at times. EGR was sooted badly as was tube. After cleaning g and replacing there was no difference in performance. Going to pull plugs next. Any other thoughts? 214k miles, uses some oil between changes but did get 26mpg until this week.
Thank you

Mike
Do you
have the same problem?
Yes
No
Saturday, August 31st, 2013 AT 12:26 PM

6 Replies

Tiny
DRCRANKNWRENCH
  • EXPERT
There might be enough oil getting past the rings that it is causing mis firing. Is there smoke coming out of the exhaust when you get on and off the gas? That is a sign that the engine is not burning all the oil and combustion is not complete. I am giving you a walk through on backfires to help you understand and diagnose the issues as it covers the most common problems. Just use the link below;

http://www.2carpros.com/articles/engine-backfires-while-running
Was this
answer
helpful?
Yes
No
Saturday, August 31st, 2013 AT 4:40 PM
Tiny
MTMCALL
  • MEMBER
There is no smoke on start up or while driving. I am going to check fuel filter this morning since its been over 100k since it was replaced. Will check the air filter and front plugs as well. Really hope its not plugs. I don't know how to remove the manifold.
What else should I take a look at?

Thank you so much for your time

Mike McAllister
Was this
answer
helpful?
Yes
No
Sunday, September 1st, 2013 AT 3:03 AM
Tiny
MTMCALL
  • MEMBER
Also, I did replace the serpentine belt 2 weeks ago. Plugs and coils are 2 years old and no EWL since I changed the EGR and cleaned the tube

Mike
Was this
answer
helpful?
Yes
No
Sunday, September 1st, 2013 AT 7:35 AM
Tiny
DRCRANKNWRENCH
  • EXPERT
Check the fuel injectors with a noid light. Just a 12 volt bulb with positive and negative leads. Touch them to injector leads and turn engine over and if it lights up injector is okay. It might be clogged, so if I did not mention it a can or 2 of quality fuel system cleaner will do wonders. BG44k is the best but you have to get it at the parts counter of car dealerships and its $20 a bottle. Sea Foam is easier to get and a good second choice. You might experience rough engine performance when you use it as it removes deposits which eventually settle in the oil pan. So, after 2 tanks of gas, each with a bottle, then one tank of gas after that be prepared to change the oil as it will get dirty.
If your fuel filter is that old it is certainly adding to the issue if not causing it. That may fix your problem.
Was this
answer
helpful?
Yes
No
Sunday, September 1st, 2013 AT 10:19 PM
Tiny
MTMCALL
  • MEMBER
Cleaned with Sea Foam last night. Ran great and now has thrown 401 code, Insufficient EGR flow.
Should I run another can then change the oil? I am going to see if the parts stores have the BG in stock.

Will also check the injectors now.

Thanks for all your advice

Mike
Was this
answer
helpful?
Yes
No
Monday, September 2nd, 2013 AT 7:34 AM
Tiny
DRCRANKNWRENCH
  • EXPERT
Yes run another can and then run an entire full tank of gas after that before you evaluate performance. However I think you still might want to check injectors. Below is a link to an extensive test of fuel injectors. It will explain symptoms, which are quite like yours but you should still run cleaner and replace filter, and tell you procedure to test injectors. Just click link below;

http://www.2carpros.com/articles/how-to-test-a-fuel-injector
Was this
answer
helpful?
Yes
No
Monday, September 2nd, 2013 AT 4:57 PM

Please login or register to post a reply.

Recommended Guides