1995 Buick Riviera horn

Tiny
DENISE SURDUKOWSKI
  • MEMBER
  • 1995 BUICK RIVIERA
Electrical problem
1995 Buick Riviera 6 cyl Front Wheel Drive Automatic

Both horns don't work. I need to register the car soon. I've replaced the 20 amp fuse and it blew. I replaced it with a 30 amp fuse and it did not blow but it didn't fix the problem. What can I do next?
Do you
have the same problem?
Yes
No
Tuesday, April 29th, 2008 AT 9:51 AM

4 Replies

Tiny
JACK42
  • MEMBER
Need to put the lower amp fuse back in it so you dont damage anything. Then locate and disconnect the horns to see if it blows the 20 amp fuse, if not replace them. Otherwise could be a short in the column wiring
Was this
answer
helpful?
Yes
No
Tuesday, April 29th, 2008 AT 12:19 PM
Tiny
BUZZSAW
  • MEMBER
Dont do that, you can fry the wires, take a test light and stick it in the disconnected horn wires have some one push the horn and see if it lights up the horn may be pulling to much amps, if it still blows the 10 fuse its in the wiring to the horn that needs to be addressed
Was this
answer
helpful?
Yes
No
Tuesday, April 29th, 2008 AT 12:21 PM
Tiny
BUZZSAW
  • MEMBER
Jack we musta been answering this at the same time cause when I posted there wasnt an answer to help these people out, Look at the time we posted lmao
Was this
answer
helpful?
Yes
No
Tuesday, April 29th, 2008 AT 3:37 PM
Tiny
JACK42
  • MEMBER
Oops lol my bad
Was this
answer
helpful?
Yes
No
Wednesday, April 30th, 2008 AT 7:18 AM

Please login or register to post a reply.

Recommended Guides